{"answers":{"affected":"2 open source packages ship an affected version, including yajl-ruby. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-16516 in the wild and no public exploit code.","fix":"Upgrade yajl-ruby to 1.3.1 or later.","what":"CVE-2017-16516 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 3 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16516 and fix it if it is affected.\n\nWhat it is: CVE-2017-16516 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 3 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16516 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yajl-ruby (RubyGems): affected all versions; fixed in 1.3.1\n- yajl-ruby (RubyGems): affected all versions; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16516/ (Markdown: https://insights.sbomify.com/CVE-2017-16516/index.md)","id":"CVE-2017-16516","markdown":"https://insights.sbomify.com/CVE-2017-16516/index.md","name":"CVE-2017-16516","record":{"aliases":["DEBIAN-CVE-2017-16516","DLA-1167-1","GHSA-wwh7-4jw9-33x6","OESA-2025-1156","UBUNTU-CVE-2017-16516"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby JSON parser","requires_auth":"none","summary":"A crafted JSON file causes the yajl-ruby library to crash the Ruby process, leading to a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"yajl-ruby","vendor":"yajl-ruby_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-134","name":"Use of Externally-Controlled Format String"}],"description":"In the yajl-ruby gem 1.3.0 for Ruby, when a crafted JSON file is supplied to Yajl::Parser.new.parse, the whole ruby process crashes with a SIGABRT in the yajl_string_decode function in yajl_encode.c. This results in the whole ruby process terminating and potentially a denial of service.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"yajl-ruby gem Denial of Service vulnerability","id":"CVE-2017-16516","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":5,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2017-16520"},"packages":[{"ecosystem":"RubyGems","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"yajl-ruby","purl":null,"source":"GHSA-wwh7-4jw9-33x6"},{"ecosystem":"RubyGems","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"yajl-ruby","purl":"pkg:gem/yajl-ruby","source":"GHSA-wwh7-4jw9-33x6"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-16514"},"products":["n/a"],"published":"2017-11-03","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A crafted JSON file causes the yajl-ruby library to crash the Ruby process, leading to a denial of service.","url":"https://insights.sbomify.com/CVE-2017-16516/"}