# CVE-2017-16558: Contao SQL injection in the backend and listing module

> An SQL injection vulnerability in Contao CMS allows attackers to read or modify database contents via the back end or listing module.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w38g-hj45-mjjp

## What is CVE-2017-16558?

CVE-2017-16558 is a critical SQL injection vulnerability in n/a, published on 25 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the back end as well as in the listing module.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2017-16558?

12 open source packages ship an affected version, including contao/contao, contao/core-bundle and contao/listing-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 3.0.0 to 3.5.30 | None |
| `contao/contao` | Packagist | From 3.0.0 to 3.5.30 | None |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.8 |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.8 |
| `contao/core-bundle` | Packagist | From 3.0.0 to 3.5.30 | None |
| `contao/core-bundle` | Packagist | From 3.0.0 to 3.5.30 | None |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.8 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.8 |
| `contao/listing-bundle` | Packagist | From 3.0.0 to 3.5.30 | None |
| `contao/listing-bundle` | Packagist | From 3.0.0 to 3.5.30 | None |
| `contao/listing-bundle` | Packagist | From 4.0.0 | 4.4.8 |
| `contao/listing-bundle` | Packagist | From 4.0.0 | 4.4.8 |

Products: Contao Contao Cms.

## How do I fix CVE-2017-16558?

Upgrade contao/contao to 4.4.8 or later.

## Is CVE-2017-16558 being exploited?

There is no known exploitation of CVE-2017-16558 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-1860](https://insights.sbomify.com/CVE-2014-1860/): Deserialization in n/a (critical 9.8)
- [CVE-2019-10641](https://insights.sbomify.com/CVE-2019-10641/): Contao Does Not Invalidate Existing Sessions When Password Changes (critical 9.8)
- [CVE-2019-10643](https://insights.sbomify.com/CVE-2019-10643/): Contao Does Not Expire Tokens Correctly (critical 9.8)
- [CVE-2019-10642](https://insights.sbomify.com/CVE-2019-10642/): Contao CSRF Token Bypass (high 8.8)
- [CVE-2017-10993](https://insights.sbomify.com/CVE-2017-10993/): Contao Core directory traversal vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16558 and fix it if it is affected.

What it is: CVE-2017-16558 is a critical SQL injection vulnerability in n/a, published on 25 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16558 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 3.0.0 up to 3.5.30; no fix listed
- contao/contao (Packagist): affected from 3.0.0 up to 3.5.30; no fix listed
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.8
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.8
- contao/core-bundle (Packagist): affected from 3.0.0 up to 3.5.30; no fix listed
- contao/core-bundle (Packagist): affected from 3.0.0 up to 3.5.30; no fix listed
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.8
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.8
- contao/listing-bundle (Packagist): affected from 3.0.0 up to 3.5.30; no fix listed
- contao/listing-bundle (Packagist): affected from 3.0.0 up to 3.5.30; no fix listed
- contao/listing-bundle (Packagist): affected from 4.0.0; fixed in 4.4.8
- contao/listing-bundle (Packagist): affected from 4.0.0; fixed in 4.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16558/ (Markdown: https://insights.sbomify.com/CVE-2017-16558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16558
- OSV: https://osv.dev/vulnerability/CVE-2017-16558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16558/
Summaries are generated and may contain mistakes; the official description above is the record.
