{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2017-16611 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-16611 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 1 Dec 2017. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16611 and fix it if it is affected.\n\nWhat it is: CVE-2017-16611 is a medium-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 1 Dec 2017. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16611 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16611/ (Markdown: https://insights.sbomify.com/CVE-2017-16611/index.md)","id":"CVE-2017-16611","markdown":"https://insights.sbomify.com/CVE-2017-16611/index.md","name":"CVE-2017-16611","record":{"aliases":["ALPINE-CVE-2017-16611","DEBIAN-CVE-2017-16611","DLA-2901-1","GHSA-vjcj-64vh-89f7","MGASA-2017-0442","UBUNTU-CVE-2017-16611","USN-3500-1","openSUSE-SU-2024:10922-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","other"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"X11 font library","requires_auth":"low_privilege","summary":"A local attacker can open arbitrary files as root in libXfont, potentially triggering system mechanisms like tape rewinds or watchdogs.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"libxfont","vendor":"x"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"In libXfont before 1.5.4 and libXfont2 before 2.0.3, a local attacker can open (but not read) files on the system as root, triggering tape rewinds, watchdogs, or similar mechanisms that can be triggered by opening files.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2017-16611","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux"],"type":"path_traversal","year":"2017"},"n_packages":1,"n_references":8,"next":{"headline":"Integer overflow in n/a","id":"CVE-2017-16612"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.0.5-1.2"],"introduced":["0"],"last_affected":[],"package":"libXfont2","purl":"pkg:rpm/opensuse/libXfont2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10922-1"}],"prev":{"headline":"Path traversal in NetGain Systems Enterprise Manager","id":"CVE-2017-16610"},"products":["n/a"],"published":"2017-12-01","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A local attacker can open arbitrary files as root in libXfont, potentially triggering system mechanisms like tape rewinds or watchdogs.","url":"https://insights.sbomify.com/CVE-2017-16611/"}