# CVE-2017-16613: OpenStack Swauth object/proxy server writing Auth Token to log file

> Attackers can steal unhashed authentication tokens from log files to bypass authentication in OpenStack Swift deployments using Swauth.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DSA-4044-1, GHSA-qhq8-xwqv-pvv9, PYSEC-2017-84, UBUNTU-CVE-2017-16613

## What is CVE-2017-16613?

CVE-2017-16613 is a critical vulnerability in Debian Debian Linux, published on 21 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in middleware.py in OpenStack Swauth through 1.2.0 when used with OpenStack Swift through 2.15.1. The Swift object store and proxy server are saving (unhashed) tokens retrieved from the Swauth middleware authentication mechanism to a log file as part of a GET URI. This allows attackers to bypass authentication by inserting a token into an X-Auth-Token header of a new request. NOTE: github.com/openstack/swauth URLs do not mean that Swauth is maintained by an official OpenStack project team.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-16613?

3 open source packages ship an affected version, including swauth. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swauth` | PyPI | All versions | 1.3.0 |
| `swauth` | PyPI | All versions | 1.3.0 |
| `swauth` | PyPI | All versions | 1.3.0 |

Products: Debian Debian Linux, Openstack Swauth, Openstack Swift.

## How do I fix CVE-2017-16613?

Upgrade swauth to 1.3.0 or later.

## Is CVE-2017-16613 being exploited?

There is no known exploitation of CVE-2017-16613 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16613 and fix it if it is affected.

What it is: CVE-2017-16613 is a critical vulnerability in Debian Debian Linux, published on 21 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16613 in the wild and no public exploit code.

Affected packages and fixed versions:
- swauth (PyPI): affected all versions; fixed in 1.3.0
- swauth (PyPI): affected all versions; fixed in 1.3.0
- swauth (PyPI): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16613/ (Markdown: https://insights.sbomify.com/CVE-2017-16613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16613
- OSV: https://osv.dev/vulnerability/CVE-2017-16613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16613/
Summaries are generated and may contain mistakes; the official description above is the record.
