{"answers":{"affected":"3 open source packages ship an affected version, including mlalchemy and MLAlchemy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16615 in the wild and no public exploit code.","fix":"Upgrade mlalchemy to 0.2.2 or later.","what":"CVE-2017-16615 is a critical unsafe deserialization vulnerability in n/a, published on 8 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16615 and fix it if it is affected.\n\nWhat it is: CVE-2017-16615 is a critical unsafe deserialization vulnerability in n/a, published on 8 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16615 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mlalchemy (PyPI): affected all versions; fixed in 0.2.2\n- mlalchemy (PyPI): affected all versions; fixed in 0.2.2\n- MLAlchemy (PyPI): affected all versions; fixed in 0.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16615/ (Markdown: https://insights.sbomify.com/CVE-2017-16615/index.md)","id":"CVE-2017-16615","markdown":"https://insights.sbomify.com/CVE-2017-16615/index.md","name":"CVE-2017-16615","record":{"aliases":["GHSA-xpm8-98mx-h4c5","PYSEC-2017-19"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python ORM library","requires_auth":"none","summary":"An attacker can execute arbitrary Python commands by inserting malicious code into YAML queries processed by the MLAlchemy library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mlalchemy","vendor":"mlalchemy_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"An exploitable vulnerability exists in the YAML parsing functionality in the parse_yaml_query method in parser.py in MLAlchemy before 0.2.2. When processing YAML-Based queries for data, a YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unsafe deserialization in MLAlchemy","id":"CVE-2017-16615","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2017"},"n_packages":3,"n_references":3,"next":{"headline":"Unsafe pyyaml load usage in PyAnyAPI","id":"CVE-2017-16616"},"packages":[{"ecosystem":"PyPI","fixed":["0.2.2"],"introduced":["0"],"last_affected":[],"package":"MLAlchemy","purl":null,"source":"GHSA-xpm8-98mx-h4c5"},{"ecosystem":"PyPI","fixed":["0.2.2"],"introduced":["0"],"last_affected":[],"package":"mlalchemy","purl":"pkg:pypi/mlalchemy","source":"GHSA-xpm8-98mx-h4c5"},{"ecosystem":"PyPI","fixed":["0.2.2"],"introduced":["0"],"last_affected":[],"package":"mlalchemy","purl":"pkg:pypi/mlalchemy","source":"PYSEC-2017-19"}],"prev":{"headline":"Server-side request forgery in n/a","id":"CVE-2017-16614"},"products":["n/a"],"published":"2017-11-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can execute arbitrary Python commands by inserting malicious code into YAML queries processed by the MLAlchemy library.","url":"https://insights.sbomify.com/CVE-2017-16615/"}