# CVE-2017-16615: Unsafe deserialization in MLAlchemy

> An attacker can execute arbitrary Python commands by inserting malicious code into YAML queries processed by the MLAlchemy library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xpm8-98mx-h4c5, PYSEC-2017-19

## What is CVE-2017-16615?

CVE-2017-16615 is a critical unsafe deserialization vulnerability in n/a, published on 8 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An exploitable vulnerability exists in the YAML parsing functionality in the parse_yaml_query method in parser.py in MLAlchemy before 0.2.2. When processing YAML-Based queries for data, a YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.

## Which versions are affected by CVE-2017-16615?

3 open source packages ship an affected version, including mlalchemy and MLAlchemy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlalchemy` | PyPI | All versions | 0.2.2 |
| `mlalchemy` | PyPI | All versions | 0.2.2 |
| `MLAlchemy` | PyPI | All versions | 0.2.2 |

Products: Mlalchemy Project Mlalchemy.

## How do I fix CVE-2017-16615?

Upgrade mlalchemy to 0.2.2 or later.

## Is CVE-2017-16615 being exploited?

There is no known exploitation of CVE-2017-16615 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16615 and fix it if it is affected.

What it is: CVE-2017-16615 is a critical unsafe deserialization vulnerability in n/a, published on 8 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16615 in the wild and no public exploit code.

Affected packages and fixed versions:
- mlalchemy (PyPI): affected all versions; fixed in 0.2.2
- mlalchemy (PyPI): affected all versions; fixed in 0.2.2
- MLAlchemy (PyPI): affected all versions; fixed in 0.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16615/ (Markdown: https://insights.sbomify.com/CVE-2017-16615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16615
- OSV: https://osv.dev/vulnerability/CVE-2017-16615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16615/
Summaries are generated and may contain mistakes; the official description above is the record.
