{"answers":{"affected":"3 open source packages ship an affected version, including pyanyapi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16616 in the wild and no public exploit code.","fix":"Upgrade pyanyapi to 0.6.1 or later.","what":"CVE-2017-16616 is a critical code injection vulnerability in n/a, published on 8 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16616 and fix it if it is affected.\n\nWhat it is: CVE-2017-16616 is a critical code injection vulnerability in n/a, published on 8 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16616 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyanyapi (PyPI): affected all versions; fixed in 0.6.1\n- pyanyapi (PyPI): affected all versions; fixed in 0.6.1\n- pyanyapi (PyPI): affected all versions; fixed in 0.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16616/ (Markdown: https://insights.sbomify.com/CVE-2017-16616/index.md)","id":"CVE-2017-16616","markdown":"https://insights.sbomify.com/CVE-2017-16616/index.md","name":"CVE-2017-16616","record":{"aliases":["GHSA-vg8g-jpm9-jh8r","PYSEC-2017-23"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python YAML parser","requires_auth":"none","summary":"Attackers can execute arbitrary Python commands via malicious YAML input due to unsafe parsing in PyAnyAPI.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pyanyapi","vendor":"pyanyapi_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unsafe pyyaml load usage in PyAnyAPI","id":"CVE-2017-16616","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":3,"n_references":4,"next":{"headline":"Unsafe deserialization in owlmixin","id":"CVE-2017-16618"},"packages":[{"ecosystem":"PyPI","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"pyanyapi","purl":null,"source":"GHSA-vg8g-jpm9-jh8r"},{"ecosystem":"PyPI","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"pyanyapi","purl":"pkg:pypi/pyanyapi","source":"GHSA-vg8g-jpm9-jh8r"},{"ecosystem":"PyPI","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"pyanyapi","purl":"pkg:pypi/pyanyapi","source":"PYSEC-2017-23"}],"prev":{"headline":"Unsafe deserialization in MLAlchemy","id":"CVE-2017-16615"},"products":["n/a"],"published":"2017-11-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary Python commands via malicious YAML input due to unsafe parsing in PyAnyAPI.","url":"https://insights.sbomify.com/CVE-2017-16616/"}