{"answers":{"affected":"3 open source packages ship an affected version, including owlmixin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16618 in the wild and no public exploit code.","fix":"Upgrade owlmixin to 2.0.0 or later.","what":"CVE-2017-16618 is a critical code injection vulnerability in n/a, published on 8 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16618 and fix it if it is affected.\n\nWhat it is: CVE-2017-16618 is a critical code injection vulnerability in n/a, published on 8 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16618 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- owlmixin (PyPI): affected all versions; fixed in 2.0.0\n- owlmixin (PyPI): affected all versions; fixed in 2.0.0\n- owlmixin (PyPI): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16618/ (Markdown: https://insights.sbomify.com/CVE-2017-16618/index.md)","id":"CVE-2017-16618","markdown":"https://insights.sbomify.com/CVE-2017-16618/index.md","name":"CVE-2017-16618","record":{"aliases":["GHSA-ccmq-qvcp-5mrm","PYSEC-2017-22"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python YAML library","requires_auth":"none","summary":"Attackers can execute arbitrary Python commands by injecting malicious code into YAML files loaded by the OwlMixin library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"owlmixin","vendor":"owlmixin_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"An exploitable vulnerability exists in the YAML loading functionality of util.py in OwlMixin before 2.0.0a12. A \"Load YAML\" string or file (aka load_yaml or load_yamlf) can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unsafe deserialization in owlmixin","id":"CVE-2017-16618","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":3,"n_references":3,"next":{"headline":"Information disclosure in n/a","id":"CVE-2017-16629"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"owlmixin","purl":null,"source":"GHSA-ccmq-qvcp-5mrm"},{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"owlmixin","purl":"pkg:pypi/owlmixin","source":"GHSA-ccmq-qvcp-5mrm"},{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"owlmixin","purl":"pkg:pypi/owlmixin","source":"PYSEC-2017-22"}],"prev":{"headline":"Unsafe pyyaml load usage in PyAnyAPI","id":"CVE-2017-16616"},"products":["n/a"],"published":"2017-11-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary Python commands by injecting malicious code into YAML files loaded by the OwlMixin library.","url":"https://insights.sbomify.com/CVE-2017-16618/"}