CVE-2017-16652 Symfony Open Redirect
Attackers can exploit an open redirect in Symfony's authentication handlers to redirect users to malicious external sites, facilitating phishing attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-16652?
CVE-2017-16652 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in Symfony 2.7.x before 2.7.38, 2.8.x before 2.8.31, 3.2.x before 3.2.14, and 3.3.x before 3.3.13. DefaultAuthenticationSuccessHandler or DefaultAuthenticationFailureHandler takes the content of the _target_path parameter and generates a redirect response, but no check is performed on the path, which could be an absolute URL to an external domain. This Open redirect vulnerability can be exploited for example to mount effective phishing attacks.
Weakness: CWE-601
Which versions are affected by CVE-2017-16652?
24 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security Packagist | From 2.7.0 | 2.7.38 |
symfony/security Packagist | From 2.7.0 | 2.7.38 |
symfony/security Packagist | From 2.8.0 | 2.8.31 |
symfony/security Packagist | From 2.8.0 | 2.8.31 |
symfony/security Packagist | From 3.2.0 | 3.2.14 |
symfony/security Packagist | From 3.2.0 | 3.2.14 |
18 more packages
symfony/security Packagist | From 3.3.0 | 3.3.13 |
symfony/security Packagist | From 3.3.0 | 3.3.13 |
symfony/security-http Packagist | From 2.7.0 | 2.7.38 |
symfony/security-http Packagist | From 2.7.0 | 2.7.38 |
symfony/security-http Packagist | From 2.8.0 | 2.8.31 |
symfony/security-http Packagist | From 2.8.0 | 2.8.31 |
symfony/security-http Packagist | From 3.2.0 | 3.2.14 |
symfony/security-http Packagist | From 3.2.0 | 3.2.14 |
symfony/security-http Packagist | From 3.3.0 | 3.3.13 |
symfony/security-http Packagist | From 3.3.0 | 3.3.13 |
symfony/symfony Packagist | From 2.7.0 | 2.7.38 |
symfony/symfony Packagist | From 2.7.0 | 2.7.38 |
symfony/symfony Packagist | From 2.8.0 | 2.8.31 |
symfony/symfony Packagist | From 2.8.0 | 2.8.31 |
symfony/symfony Packagist | From 3.2.0 | 3.2.14 |
symfony/symfony Packagist | From 3.2.0 | 3.2.14 |
symfony/symfony Packagist | From 3.3.0 | 3.3.13 |
symfony/symfony Packagist | From 3.3.0 | 3.3.13 |
Products include Debian Debian Linux, Sensiolabs Symfony.
How do I fix CVE-2017-16652?
Upgrade symfony/security to a fixed version for your release line: 2.7.38, 2.8.31, 3.2.14 or 3.3.13.
Is CVE-2017-16652 being exploited?
There is no known exploitation of CVE-2017-16652 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2017-16652, GHSA-r7p7-qr7p-2rrf, UBUNTU-CVE-2017-16652.