# CVE-2017-16652: Symfony Open Redirect

> Attackers can exploit an open redirect in Symfony's authentication handlers to redirect users to malicious external sites, facilitating phishing attacks.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-16652, GHSA-r7p7-qr7p-2rrf, UBUNTU-CVE-2017-16652

## What is CVE-2017-16652?

CVE-2017-16652 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Symfony 2.7.x before 2.7.38, 2.8.x before 2.8.31, 3.2.x before 3.2.14, and 3.3.x before 3.3.13. DefaultAuthenticationSuccessHandler or DefaultAuthenticationFailureHandler takes the content of the _target_path parameter and generates a redirect response, but no check is performed on the path, which could be an absolute URL to an external domain. This Open redirect vulnerability can be exploited for example to mount effective phishing attacks.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2017-16652?

24 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/security` | Packagist | From 3.2.0 | 3.2.14 |
| `symfony/security` | Packagist | From 3.2.0 | 3.2.14 |
| `symfony/security` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/security` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/security-http` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/security-http` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/security-http` | Packagist | From 3.2.0 | 3.2.14 |
| `symfony/security-http` | Packagist | From 3.2.0 | 3.2.14 |
| `symfony/security-http` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/security-http` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/symfony` | Packagist | From 3.2.0 | 3.2.14 |
| `symfony/symfony` | Packagist | From 3.2.0 | 3.2.14 |
| `symfony/symfony` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/symfony` | Packagist | From 3.3.0 | 3.3.13 |

Products: Debian Debian Linux, Sensiolabs Symfony.

## How do I fix CVE-2017-16652?

Upgrade symfony/security to a fixed version for your release line: 2.7.38, 2.8.31, 3.2.14 or 3.3.13.

## Is CVE-2017-16652 being exploited?

There is no known exploitation of CVE-2017-16652 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16652 and fix it if it is affected.

What it is: CVE-2017-16652 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-16652 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.38
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.38
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.31
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.31
- symfony/security (Packagist): affected from 3.2.0; fixed in 3.2.14
- symfony/security (Packagist): affected from 3.2.0; fixed in 3.2.14
- symfony/security (Packagist): affected from 3.3.0; fixed in 3.3.13
- symfony/security (Packagist): affected from 3.3.0; fixed in 3.3.13
- symfony/security-http (Packagist): affected from 2.7.0; fixed in 2.7.38
- symfony/security-http (Packagist): affected from 2.7.0; fixed in 2.7.38
- symfony/security-http (Packagist): affected from 2.8.0; fixed in 2.8.31
- symfony/security-http (Packagist): affected from 2.8.0; fixed in 2.8.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16652/ (Markdown: https://insights.sbomify.com/CVE-2017-16652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16652
- OSV: https://osv.dev/vulnerability/CVE-2017-16652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16652/
Summaries are generated and may contain mistakes; the official description above is the record.
