CVE-2017-16653 Symfony CSRF Vulnerability
Attackers can bypass CSRF protection by exploiting shared tokens across HTTP and HTTPS, enabling cross-site request forgery attacks against Symfony applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-16653?
CVE-2017-16653 is a medium-severity vulnerability in Debian Debian Linux, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The current implementation of CSRF protection in Symfony (Version >=2) does not use different tokens for HTTP and HTTPS; therefore the token is subject to MITM attacks on HTTP and can then be used in an HTTPS context to do CSRF attacks.
Which versions are affected by CVE-2017-16653?
24 open source packages ship an affected version, including symfony/security, symfony/security-csrf and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security Packagist | From 2.7.0 | 2.7.38 |
symfony/security Packagist | From 2.7.0 | 2.7.38 |
symfony/security Packagist | From 2.8.0 | 2.8.31 |
symfony/security Packagist | From 2.8.0 | 2.8.31 |
symfony/security Packagist | From 3.0.0 | 3.2.14 |
symfony/security Packagist | From 3.0.0 | 3.2.14 |
18 more packages
symfony/security Packagist | From 3.3.0 | 3.3.13 |
symfony/security Packagist | From 3.3.0 | 3.3.13 |
symfony/security-csrf Packagist | From 2.7.0 | 2.7.38 |
symfony/security-csrf Packagist | From 2.7.0 | 2.7.38 |
symfony/security-csrf Packagist | From 2.8.0 | 2.8.31 |
symfony/security-csrf Packagist | From 2.8.0 | 2.8.31 |
symfony/security-csrf Packagist | From 3.0.0 | 3.2.14 |
symfony/security-csrf Packagist | From 3.0.0 | 3.2.14 |
symfony/security-csrf Packagist | From 3.3.0 | 3.3.13 |
symfony/security-csrf Packagist | From 3.3.0 | 3.3.13 |
symfony/symfony Packagist | From 2.7.0 | 2.7.38 |
symfony/symfony Packagist | From 2.7.0 | 2.7.38 |
symfony/symfony Packagist | From 2.8.0 | 2.8.31 |
symfony/symfony Packagist | From 2.8.0 | 2.8.31 |
symfony/symfony Packagist | From 3.0.0 | 3.2.14 |
symfony/symfony Packagist | From 3.0.0 | 3.2.14 |
symfony/symfony Packagist | From 3.3.0 | 3.3.13 |
symfony/symfony Packagist | From 3.3.0 | 3.3.13 |
Products include Debian Debian Linux, Sensiolabs Symfony.
How do I fix CVE-2017-16653?
Upgrade symfony/security to a fixed version for your release line: 2.7.38, 2.8.31, 3.2.14 or 3.3.13.
Is CVE-2017-16653 being exploited?
There is no known exploitation of CVE-2017-16653 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2017-16653, GHSA-92x6-h2gr-8gxq, UBUNTU-CVE-2017-16653.