# CVE-2017-16653: Symfony CSRF Vulnerability

> Attackers can bypass CSRF protection by exploiting shared tokens across HTTP and HTTPS, enabling cross-site request forgery attacks against Symfony applications.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-16653, GHSA-92x6-h2gr-8gxq, UBUNTU-CVE-2017-16653

## What is CVE-2017-16653?

CVE-2017-16653 is a medium-severity vulnerability in Debian Debian Linux, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The current implementation of CSRF protection in Symfony (Version >=2) does not use different tokens for HTTP and HTTPS; therefore the token is subject to MITM attacks on HTTP and can then be used in an HTTPS context to do CSRF attacks.

## Which versions are affected by CVE-2017-16653?

24 open source packages ship an affected version, including symfony/security, symfony/security-csrf and symfony/symfony. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/security` | Packagist | From 3.0.0 | 3.2.14 |
| `symfony/security` | Packagist | From 3.0.0 | 3.2.14 |
| `symfony/security` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/security` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/security-csrf` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/security-csrf` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/security-csrf` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/security-csrf` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/security-csrf` | Packagist | From 3.0.0 | 3.2.14 |
| `symfony/security-csrf` | Packagist | From 3.0.0 | 3.2.14 |
| `symfony/security-csrf` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/security-csrf` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.38 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.31 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.2.14 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.2.14 |
| `symfony/symfony` | Packagist | From 3.3.0 | 3.3.13 |
| `symfony/symfony` | Packagist | From 3.3.0 | 3.3.13 |

Products: Debian Debian Linux, Sensiolabs Symfony.

## How do I fix CVE-2017-16653?

Upgrade symfony/security to a fixed version for your release line: 2.7.38, 2.8.31, 3.2.14 or 3.3.13.

## Is CVE-2017-16653 being exploited?

There is no known exploitation of CVE-2017-16653 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16653 and fix it if it is affected.

What it is: CVE-2017-16653 is a medium-severity vulnerability in Debian Debian Linux, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16653 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.38
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.38
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.31
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.31
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.2.14
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.2.14
- symfony/security (Packagist): affected from 3.3.0; fixed in 3.3.13
- symfony/security (Packagist): affected from 3.3.0; fixed in 3.3.13
- symfony/security-csrf (Packagist): affected from 2.7.0; fixed in 2.7.38
- symfony/security-csrf (Packagist): affected from 2.7.0; fixed in 2.7.38
- symfony/security-csrf (Packagist): affected from 2.8.0; fixed in 2.8.31
- symfony/security-csrf (Packagist): affected from 2.8.0; fixed in 2.8.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16653/ (Markdown: https://insights.sbomify.com/CVE-2017-16653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16653
- OSV: https://osv.dev/vulnerability/CVE-2017-16653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16653/
Summaries are generated and may contain mistakes; the official description above is the record.
