CVE-2017-16654 Symfony Directory Traversal
An attacker can exploit directory traversal in the Symfony Intl component to read arbitrary files from the local filesystem via untrusted locale input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-16654?
CVE-2017-16654 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The Intl component includes various bundle readers that are used to read resource bundles from the local filesystem. The read() methods of these classes use a path and a locale to determine the language bundle to retrieve. The locale argument value is commonly retrieved from untrusted user input (like a URL parameter). An attacker can use this argument to navigate to arbitrary directories via the dot-dot-slash attack, aka Directory Traversal.
Weakness: CWE-22
Which versions are affected by CVE-2017-16654?
16 open source packages ship an affected version, including symfony/intl and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/intl Packagist | From 2.7.0 | 2.7.38 |
symfony/intl Packagist | From 2.7.0 | 2.7.38 |
symfony/intl Packagist | From 2.8.0 | 2.8.31 |
symfony/intl Packagist | From 2.8.0 | 2.8.31 |
symfony/intl Packagist | From 3.0.0 | 3.2.14 |
symfony/intl Packagist | From 3.0.0 | 3.2.14 |
10 more packages
symfony/intl Packagist | From 3.3.0 | 3.3.13 |
symfony/intl Packagist | From 3.3.0 | 3.3.13 |
symfony/symfony Packagist | From 2.7.0 | 2.7.38 |
symfony/symfony Packagist | From 2.7.0 | 2.7.38 |
symfony/symfony Packagist | From 2.8.0 | 2.8.31 |
symfony/symfony Packagist | From 2.8.0 | 2.8.31 |
symfony/symfony Packagist | From 3.0.0 | 3.2.14 |
symfony/symfony Packagist | From 3.0.0 | 3.2.14 |
symfony/symfony Packagist | From 3.3.0 | 3.3.13 |
symfony/symfony Packagist | From 3.3.0 | 3.3.13 |
Products include Debian Debian Linux, Sensiolabs Symfony.
How do I fix CVE-2017-16654?
Upgrade symfony/intl to a fixed version for your release line: 2.7.38, 2.8.31, 3.2.14 or 3.3.13.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2017-16654 being exploited?
There is no known exploitation of CVE-2017-16654 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2017-16654, GHSA-c49r-8gj6-768r, UBUNTU-CVE-2017-16654.