# CVE-2017-16754: Bolt Improper Access Control

> Attackers can access restricted profiler routes in Bolt CMS to view sensitive debugging information due to missing authorization checks.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wr23-m9m2-jjf4

## What is CVE-2017-16754?

CVE-2017-16754 is a medium-severity missing authorization vulnerability in n/a, published on 9 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bolt before 3.3.6 does not properly restrict access to _profiler routes, related to EventListener/ProfilerListener.php and Provider/EventListenerServiceProvider.php.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2017-16754?

2 open source packages ship an affected version, including bolt/bolt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bolt/bolt` | Packagist | All versions | 3.3.6 |
| `bolt/bolt` | Packagist | All versions | 3.3.6 |

Products: Boltcms Bolt.

## How do I fix CVE-2017-16754?

Upgrade bolt/bolt to 3.3.6 or later.

## Is CVE-2017-16754 being exploited?

There is no known exploitation of CVE-2017-16754 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-31321](https://insights.sbomify.com/CVE-2022-31321/): Path traversal in n/a (critical 9.1)
- [CVE-2019-10874](https://insights.sbomify.com/CVE-2019-10874/): Bolt Cross Site Request Forgery (CSRF) (high 8.8)
- [CVE-2019-9185](https://insights.sbomify.com/CVE-2019-9185/): Bolt Unrestricted Upload of File with Dangerous Type (high 8.8)
- [CVE-2020-4040](https://insights.sbomify.com/CVE-2020-4040/): CSRF issue on preview pages in Bolt CMS (high 8.6)
- [CVE-2025-34086](https://insights.sbomify.com/CVE-2025-34086/): Bolt CMS Authenticated Remote Code Execution via Profile Injection and File Rename (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16754 and fix it if it is affected.

What it is: CVE-2017-16754 is a medium-severity missing authorization vulnerability in n/a, published on 9 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16754 in the wild and no public exploit code.

Affected packages and fixed versions:
- bolt/bolt (Packagist): affected all versions; fixed in 3.3.6
- bolt/bolt (Packagist): affected all versions; fixed in 3.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16754/ (Markdown: https://insights.sbomify.com/CVE-2017-16754/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16754
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16754
- OSV: https://osv.dev/vulnerability/CVE-2017-16754

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16754/
Summaries are generated and may contain mistakes; the official description above is the record.
