# CVE-2017-16762: Sanic arbitrary file read and directory traversal

> An attacker can read arbitrary files from the server via directory traversal in the Sanic web framework.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mpmf-hr8p-p49g, PYSEC-2017-40

## What is CVE-2017-16762?

CVE-2017-16762 is a high-severity path traversal vulnerability in n/a, published on 10 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sanic before 0.5.1 allows reading arbitrary files with directory traversal, as demonstrated by the /static/..%2f substring.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-16762?

3 open source packages ship an affected version, including sanic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanic` | PyPI | All versions | 0.5.1 |
| `sanic` | PyPI | All versions | 0.5.1 |
| `sanic` | PyPI | All versions | 0.5.1 |

Products: Sanic Project Sanic.

## How do I fix CVE-2017-16762?

Upgrade sanic to 0.5.1 or later.

## Is CVE-2017-16762 being exploited?

There is no known exploitation of CVE-2017-16762 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-35920](https://insights.sbomify.com/CVE-2022-35920/): Improper Limitation of a Pathname to a Restricted Directory in sanic (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16762 and fix it if it is affected.

What it is: CVE-2017-16762 is a high-severity path traversal vulnerability in n/a, published on 10 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16762 in the wild and no public exploit code.

Affected packages and fixed versions:
- sanic (PyPI): affected all versions; fixed in 0.5.1
- sanic (PyPI): affected all versions; fixed in 0.5.1
- sanic (PyPI): affected all versions; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16762/ (Markdown: https://insights.sbomify.com/CVE-2017-16762/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16762
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16762
- OSV: https://osv.dev/vulnerability/CVE-2017-16762

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16762/
Summaries are generated and may contain mistakes; the official description above is the record.
