{"answers":{"affected":"3 open source packages ship an affected version, including confire. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16763 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-16763 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-16763 is a critical code injection vulnerability in n/a, published on 10 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16763 and fix it if it is affected.\n\nWhat it is: CVE-2017-16763 is a critical code injection vulnerability in n/a, published on 10 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16763 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- confire (PyPI): affected all versions up to 0.2.0; no fix listed\n- confire (PyPI): affected all versions up to 0.2.0; no fix listed\n- confire (PyPI): affected from 0.1.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16763/ (Markdown: https://insights.sbomify.com/CVE-2017-16763/index.md)","id":"CVE-2017-16763","markdown":"https://insights.sbomify.com/CVE-2017-16763/index.md","name":"CVE-2017-16763","record":{"aliases":["GHSA-m85c-9mf8-m2m6","PYSEC-2017-78"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python configuration library","requires_auth":"none","summary":"Attackers can execute arbitrary Python code by inserting malicious payloads into the user-specific YAML configuration file loaded by the Confire library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"confire","vendor":"confire_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"An exploitable vulnerability exists in the YAML parsing functionality in config.py in Confire 0.2.0. Due to the user-specific configuration being loaded from \"~/.confire.yaml\" using the yaml.load function, a YAML parser can execute arbitrary Python commands resulting in command execution. An attacker can insert Python into loaded YAML to trigger this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Unsafe deserialization in confire","id":"CVE-2017-16763","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":3,"n_references":3,"next":{"headline":"django_make_app is vulnerable to Code Injection","id":"CVE-2017-16764"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.2.0"],"package":"confire","purl":null,"source":"GHSA-m85c-9mf8-m2m6"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.2.0"],"package":"confire","purl":"pkg:pypi/confire","source":"GHSA-m85c-9mf8-m2m6"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.1.0"],"last_affected":[],"package":"confire","purl":"pkg:pypi/confire","source":"PYSEC-2017-78"}],"prev":{"headline":"Sanic arbitrary file read and directory traversal","id":"CVE-2017-16762"},"products":["n/a"],"published":"2017-11-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary Python code by inserting malicious payloads into the user-specific YAML configuration file loaded by the Confire library.","url":"https://insights.sbomify.com/CVE-2017-16763/"}