{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16801 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2017-16801 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-16801 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Nov 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-16801 and fix it if it is affected.\n\nWhat it is: CVE-2017-16801 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Nov 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-16801 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16801/ (Markdown: https://insights.sbomify.com/CVE-2017-16801/index.md)","id":"CVE-2017-16801","markdown":"https://insights.sbomify.com/CVE-2017-16801/index.md","name":"CVE-2017-16801","record":{"aliases":["GHSA-3p8q-7cfq-r67x"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Octopus Deploy","requires_auth":"low_privilege","summary":"Remote authenticated users can inject arbitrary web script or HTML via the Step Template Name parameter in Octopus Deploy.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"octopus_deploy","vendor":"octopus"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in Octopus Deploy 3.7.0-3.17.13 (fixed in 3.17.14) allows remote authenticated users to inject arbitrary web script or HTML via the Step Template Name parameter.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cross-site scripting in n/a","id":"CVE-2017-16801","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2017"},"n_packages":0,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-16802"},"packages":[],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-16799"},"products":["n/a"],"published":"2017-11-13","related":[{"cvss_score":8.8,"headline":"Privilege escalation in n/a","id":"CVE-2020-10678","kev_date_added":null,"published":"2020-03-19"},{"cvss_score":8.8,"headline":"An issue was discovered in Octopus Deploy before 4.1.9.","id":"CVE-2018-5706","kev_date_added":null,"published":"2018-01-16"},{"cvss_score":8.8,"headline":"Privilege escalation in n/a","id":"CVE-2018-4862","kev_date_added":null,"published":"2018-01-03"},{"cvss_score":8.8,"headline":"Missing authorization in n/a","id":"CVE-2017-17665","kev_date_added":null,"published":"2017-12-13"},{"cvss_score":8.1,"headline":"Missing authorization in n/a","id":"CVE-2019-11632","kev_date_added":null,"published":"2019-05-01"},{"cvss_score":7.8,"headline":"Privilege escalation in Octopus Server","id":"CVE-2021-26556","kev_date_added":null,"published":"2021-10-07"},{"cvss_score":7.5,"headline":"Missing authorization in Octopus Server","id":"CVE-2022-2013","kev_date_added":null,"published":"2022-06-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote authenticated users can inject arbitrary web script or HTML via the Step Template Name parameter in Octopus Deploy.","url":"https://insights.sbomify.com/CVE-2017-16801/"}