CVE-2017-16807 Kirby XSS Vulnerability
Attackers can execute arbitrary scripts in the Kirby Panel by uploading malicious SVG files, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-16807?
CVE-2017-16807 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Nov 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a specially prepared SVG document that has been uploaded as a content file.
Weakness: CWE-79
Which versions are affected by CVE-2017-16807?
6 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 2.3.3 |
getkirby/cms Packagist | All versions | 2.3.3 |
getkirby/cms Packagist | From 2.4 | 2.4.2 |
getkirby/cms Packagist | From 2.4 | 2.4.2 |
getkirby/cms Packagist | From 2.5 | 2.5.7 |
getkirby/cms Packagist | From 2.5 | 2.5.7 |
Products include Getkirby Panel.
How do I fix CVE-2017-16807?
Upgrade getkirby/cms to a fixed version for your release line: 2.3.3, 2.4.2 or 2.5.7.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-16807 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-16807 exists.
Public exploit code: 1 Exploit-DB entry.
Sources
Also known as GHSA-275c-v3rc-xghx.