{"answers":{"affected":"6 open source packages ship an affected version, including getkirby/cms. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-16807 exists.","fix":"Upgrade getkirby/cms to a fixed version for your release line: 2.3.3, 2.4.2 or 2.5.7.","what":"CVE-2017-16807 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Nov 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-16807 and fix it if it is affected.\n\nWhat it is: CVE-2017-16807 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Nov 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-16807 exists.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected all versions; fixed in 2.3.3\n- getkirby/cms (Packagist): affected all versions; fixed in 2.3.3\n- getkirby/cms (Packagist): affected from 2.4; fixed in 2.4.2\n- getkirby/cms (Packagist): affected from 2.4; fixed in 2.4.2\n- getkirby/cms (Packagist): affected from 2.5; fixed in 2.5.7\n- getkirby/cms (Packagist): affected from 2.5; fixed in 2.5.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16807/ (Markdown: https://insights.sbomify.com/CVE-2017-16807/index.md)","id":"CVE-2017-16807","markdown":"https://insights.sbomify.com/CVE-2017-16807/index.md","name":"CVE-2017-16807","record":{"aliases":["GHSA-275c-v3rc-xghx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Kirby CMS Panel","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts in the Kirby Panel by uploading malicious SVG files, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"panel","vendor":"getkirby"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a specially prepared SVG document that has been uploaded as a content file.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2017-11-13","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2017-11-13","kind":"exploitdb","ref":"43140","stars":null,"title":"Kirby CMS \u003c 2.5.7 - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Kirby XSS Vulnerability","id":"CVE-2017-16807","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":6,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2017-16808"},"packages":[{"ecosystem":"Packagist","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-275c-v3rc-xghx"},{"ecosystem":"Packagist","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-275c-v3rc-xghx"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-275c-v3rc-xghx"},{"ecosystem":"Packagist","fixed":["2.4.2"],"introduced":["2.4"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-275c-v3rc-xghx"},{"ecosystem":"Packagist","fixed":["2.5.7"],"introduced":["2.5"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-275c-v3rc-xghx"},{"ecosystem":"Packagist","fixed":["2.5.7"],"introduced":["2.5"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-275c-v3rc-xghx"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2017-16806"},"products":["n/a"],"published":"2017-11-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts in the Kirby Panel by uploading malicious SVG files, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2017-16807/"}