# CVE-2017-16807: Kirby XSS Vulnerability

> Attackers can execute arbitrary scripts in the Kirby Panel by uploading malicious SVG files, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-275c-v3rc-xghx

## What is CVE-2017-16807?

CVE-2017-16807 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Nov 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a specially prepared SVG document that has been uploaded as a content file.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-16807?

6 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 2.3.3 |
| `getkirby/cms` | Packagist | All versions | 2.3.3 |
| `getkirby/cms` | Packagist | From 2.4 | 2.4.2 |
| `getkirby/cms` | Packagist | From 2.4 | 2.4.2 |
| `getkirby/cms` | Packagist | From 2.5 | 2.5.7 |
| `getkirby/cms` | Packagist | From 2.5 | 2.5.7 |

Products: Getkirby Panel.

## How do I fix CVE-2017-16807?

Upgrade getkirby/cms to a fixed version for your release line: 2.3.3, 2.4.2 or 2.5.7.

## Is CVE-2017-16807 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-16807 exists.

Public exploit code:

- Kirby CMS < 2.5.7 - Cross-Site Scripting (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16807 and fix it if it is affected.

What it is: CVE-2017-16807 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Nov 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-16807 exists.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 2.3.3
- getkirby/cms (Packagist): affected all versions; fixed in 2.3.3
- getkirby/cms (Packagist): affected from 2.4; fixed in 2.4.2
- getkirby/cms (Packagist): affected from 2.4; fixed in 2.4.2
- getkirby/cms (Packagist): affected from 2.5; fixed in 2.5.7
- getkirby/cms (Packagist): affected from 2.5; fixed in 2.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16807/ (Markdown: https://insights.sbomify.com/CVE-2017-16807/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16807
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16807
- OSV: https://osv.dev/vulnerability/CVE-2017-16807

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16807/
Summaries are generated and may contain mistakes; the official description above is the record.
