# CVE-2017-16833: Gemirro Stored XSS in Gemspec "homepage" value

> Attackers can inject arbitrary web script via crafted URLs in Gemirro gemspec files, potentially executing code in user browsers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-x7p2-x2j6-mwhr

## What is CVE-2017-16833?

CVE-2017-16833 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Stored cross-site scripting (XSS) vulnerability in Gemirro before 0.16.0 allows attackers to inject arbitrary web script via a crafted javascript: URL in the "homepage" value of a ".gemspec" file.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-16833?

2 open source packages ship an affected version, including gemirro. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gemirro` | RubyGems | All versions | 0.16.0 |
| `gemirro` | RubyGems | All versions | 0.16.0 |

Products: Gemirro Project Gemirro.

## How do I fix CVE-2017-16833?

Upgrade gemirro to 0.16.0 or later.

## Is CVE-2017-16833 being exploited?

There is no known exploitation of CVE-2017-16833 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16833 and fix it if it is affected.

What it is: CVE-2017-16833 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-16833 in the wild and no public exploit code.

Affected packages and fixed versions:
- gemirro (RubyGems): affected all versions; fixed in 0.16.0
- gemirro (RubyGems): affected all versions; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16833/ (Markdown: https://insights.sbomify.com/CVE-2017-16833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16833
- OSV: https://osv.dev/vulnerability/CVE-2017-16833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16833/
Summaries are generated and may contain mistakes; the official description above is the record.
