{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16837 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2017-16837 is a high-severity code injection vulnerability in n/a, published on 16 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16837 and fix it if it is affected.\n\nWhat it is: CVE-2017-16837 is a high-severity code injection vulnerability in n/a, published on 16 Nov 2017. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16837 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16837/ (Markdown: https://insights.sbomify.com/CVE-2017-16837/index.md)","id":"CVE-2017-16837","markdown":"https://insights.sbomify.com/CVE-2017-16837/index.md","name":"CVE-2017-16837","record":{"aliases":["GHSA-86m6-cj8w-2c48","SUSE-SU-2017:3090-1","UBUNTU-CVE-2017-16837","openSUSE-SU-2024:11424-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["code_execution","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Trusted Boot","requires_auth":"low_privilege","summary":"Local attackers can execute arbitrary code and overwrite TPM PCRs by exploiting unvalidated function pointers in Trusted Boot.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"trusted_boot","vendor":"trusted_boot_project"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Certain function pointers in Trusted Boot (tboot) through 1.9.6 are not validated and can cause arbitrary code execution, which allows local users to overwrite dynamic PCRs of Trusted Platform Module (TPM) by hooking these function pointers.","ecosystems":["SUSE:Linux Enterprise Server 12 SP2","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 12 SP2","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in n/a","id":"CVE-2017-16837","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2017"},"n_packages":5,"n_references":2,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2017-16839"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP2","fixed":["20160518_1.9.4-7.5.1"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/suse/tboot\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP2","source":"SUSE-SU-2017:3090-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["20160518_1.9.4-7.5.1"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/suse/tboot\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2017:3090-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP2","fixed":["20160518_1.9.4-7.5.1"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/suse/tboot\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP2","source":"SUSE-SU-2017:3090-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["20160518_1.9.4-7.5.1"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/suse/tboot\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2017:3090-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["20210614_1.10.2-2.2"],"introduced":["0"],"last_affected":[],"package":"tboot","purl":"pkg:rpm/opensuse/tboot\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11424-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-16836"},"products":["n/a"],"published":"2017-11-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Local attackers can execute arbitrary code and overwrite TPM PCRs by exploiting unvalidated function pointers in Trusted Boot.","url":"https://insights.sbomify.com/CVE-2017-16837/"}