{"answers":{"affected":"2 open source packages ship an affected version, including next. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-16877 exists.","fix":"Upgrade next to 2.4.1 or later.","what":"CVE-2017-16877 is a high-severity path traversal vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16877 and fix it if it is affected.\n\nWhat it is: CVE-2017-16877 is a high-severity path traversal vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-16877 exists.\n\nAffected packages and fixed versions:\n- next (npm): affected from 1.0.0; fixed in 2.4.1\n- next (npm): affected from 1.0.0; fixed in 2.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16877/ (Markdown: https://insights.sbomify.com/CVE-2017-16877/index.md)","id":"CVE-2017-16877","markdown":"https://insights.sbomify.com/CVE-2017-16877/index.md","name":"CVE-2017-16877","record":{"aliases":["GHSA-3f5c-4qxj-vmpf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Next.js framework","requires_auth":"none","summary":"Attackers can exploit directory traversal in Next.js to access sensitive files via specific request namespaces.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"next.js","vendor":"zeit"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"ZEIT Next.js before 2.4.1 has directory traversal under the /_next and /static request namespace, allowing attackers to obtain sensitive information.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2017/CVE-2017-16877.yaml","stars":null,"title":"Nextjs \u003c2.4.1 - Local File Inclusion"}],"tier":"weaponised"},"has_fix":true,"headline":"Next.js Directory Traversal Vulnerability","id":"CVE-2017-16877","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-16878"},"packages":[{"ecosystem":"npm","fixed":["2.4.1"],"introduced":["1.0.0"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-3f5c-4qxj-vmpf"},{"ecosystem":"npm","fixed":["2.4.1"],"introduced":["1.0.0"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-3f5c-4qxj-vmpf"}],"prev":{"headline":"mistune Cross-site scripting (XSS) vulnerability","id":"CVE-2017-16876"},"products":["n/a"],"published":"2017-11-17","related":[{"cvss_score":7.5,"headline":"Directory traversal vulnerability in Next.js","id":"CVE-2018-6184","kev_date_added":null,"published":"2018-01-24"},{"cvss_score":6.1,"headline":"Next.js has cross site scripting (XSS) vulnerability via the 404 or 500 /_error page","id":"CVE-2018-18282","kev_date_added":null,"published":"2018-10-12"},{"cvss_score":4.4,"headline":"Directory Traversal in Next.js versions below 9.3.2","id":"CVE-2020-5284","kev_date_added":null,"published":"2020-03-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can exploit directory traversal in Next.js to access sensitive files via specific request namespaces.","url":"https://insights.sbomify.com/CVE-2017-16877/"}