# CVE-2017-16877: Next.js Directory Traversal Vulnerability

> Attackers can exploit directory traversal in Next.js to access sensitive files via specific request namespaces.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-3f5c-4qxj-vmpf

## What is CVE-2017-16877?

CVE-2017-16877 is a high-severity path traversal vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ZEIT Next.js before 2.4.1 has directory traversal under the /_next and /static request namespace, allowing attackers to obtain sensitive information.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-16877?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 1.0.0 | 2.4.1 |
| `next` | npm | From 1.0.0 | 2.4.1 |

Products: Zeit Next.js.

## How do I fix CVE-2017-16877?

Upgrade next to 2.4.1 or later.

## Is CVE-2017-16877 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-16877 exists.

Public exploit code:

- Nextjs <2.4.1 - Local File Inclusion (nuclei): http/cves/2017/CVE-2017-16877.yaml

## Other vulnerabilities in n/a

- [CVE-2018-6184](https://insights.sbomify.com/CVE-2018-6184/): Directory traversal vulnerability in Next.js (high 7.5)
- [CVE-2018-18282](https://insights.sbomify.com/CVE-2018-18282/): Next.js has cross site scripting (XSS) vulnerability via the 404 or 500 /_error page (medium 6.1)
- [CVE-2020-5284](https://insights.sbomify.com/CVE-2020-5284/): Directory Traversal in Next.js versions below 9.3.2 (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16877 and fix it if it is affected.

What it is: CVE-2017-16877 is a high-severity path traversal vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-16877 exists.

Affected packages and fixed versions:
- next (npm): affected from 1.0.0; fixed in 2.4.1
- next (npm): affected from 1.0.0; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16877/ (Markdown: https://insights.sbomify.com/CVE-2017-16877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16877
- OSV: https://osv.dev/vulnerability/CVE-2017-16877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16877/
Summaries are generated and may contain mistakes; the official description above is the record.
