{"answers":{"affected":"2 open source packages ship an affected version, including filp/whoops. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16880 in the wild and no public exploit code.","fix":"Upgrade filp/whoops to 2.1.13 or later.","what":"CVE-2017-16880 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-16880 and fix it if it is affected.\n\nWhat it is: CVE-2017-16880 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-16880 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- filp/whoops (Packagist): affected all versions; fixed in 2.1.13\n- filp/whoops (Packagist): affected all versions; fixed in 2.1.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16880/ (Markdown: https://insights.sbomify.com/CVE-2017-16880/index.md)","id":"CVE-2017-16880","markdown":"https://insights.sbomify.com/CVE-2017-16880/index.md","name":"CVE-2017-16880","record":{"aliases":["GHSA-2jjm-6whx-p8w4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP error handling library","requires_auth":"none","summary":"Cross-site scripting vulnerability in the dump function of the Whoops PHP library allows attackers to inject malicious scripts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"whoops","vendor":"whoops_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The dump function in Util/TemplateHelper.php in filp whoops before 2.1.13 has XSS.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"filp whoops Cross-site Scripting vulnerability","id":"CVE-2017-16880","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-16881"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.13"],"introduced":["0"],"last_affected":[],"package":"filp/whoops","purl":null,"source":"GHSA-2jjm-6whx-p8w4"},{"ecosystem":"Packagist","fixed":["2.1.13"],"introduced":["0"],"last_affected":[],"package":"filp/whoops","purl":"pkg:composer/filp/whoops","source":"GHSA-2jjm-6whx-p8w4"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-16879"},"products":["n/a"],"published":"2017-11-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the dump function of the Whoops PHP library allows attackers to inject malicious scripts.","url":"https://insights.sbomify.com/CVE-2017-16880/"}