{"answers":{"affected":"2 open source packages ship an affected version, including passport-wsfed-saml2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16897 in the wild and no public exploit code.","fix":"Upgrade passport-wsfed-saml2 to 3.0.5 or later.","what":"CVE-2017-16897 is a high-severity authentication bypass vulnerability in n/a, published on 23 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16897 and fix it if it is affected.\n\nWhat it is: CVE-2017-16897 is a high-severity authentication bypass vulnerability in n/a, published on 23 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16897 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passport-wsfed-saml2 (npm): affected all versions; fixed in 3.0.5\n- passport-wsfed-saml2 (npm): affected all versions; fixed in 3.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16897/ (Markdown: https://insights.sbomify.com/CVE-2017-16897/index.md)","id":"CVE-2017-16897","markdown":"https://insights.sbomify.com/CVE-2017-16897/index.md","name":"CVE-2017-16897","record":{"aliases":["GHSA-77fw-rf4v-vfp9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js SAML library","requires_auth":"none","summary":"Attackers can impersonate users and escalate privileges if the SAML identity provider does not sign the full response.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"passport-wsfed-saml2","vendor":"auth0"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions \u003c 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"passport-wsfed-saml2 vulnerable to Signature Bypass in SAML2 token","id":"CVE-2017-16897","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2017-16898"},"packages":[{"ecosystem":"npm","fixed":["3.0.5"],"introduced":["0"],"last_affected":[],"package":"passport-wsfed-saml2","purl":null,"source":"GHSA-77fw-rf4v-vfp9"},{"ecosystem":"npm","fixed":["3.0.5"],"introduced":["0"],"last_affected":[],"package":"passport-wsfed-saml2","purl":"pkg:npm/passport-wsfed-saml2","source":"GHSA-77fw-rf4v-vfp9"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2017-16896"},"products":["n/a"],"published":"2017-12-23","related":[{"cvss_score":5.3,"headline":"Passport-wsfed-saml2 vulnerable to Authentication Bypass for WSFed authentication","id":"CVE-2022-23505","kev_date_added":null,"published":"2022-12-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can impersonate users and escalate privileges if the SAML identity provider does not sign the full response.","url":"https://insights.sbomify.com/CVE-2017-16897/"}