# CVE-2017-16897: passport-wsfed-saml2 vulnerable to Signature Bypass in SAML2 token

> Attackers can impersonate users and escalate privileges if the SAML identity provider does not sign the full response.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-77fw-rf4v-vfp9

## What is CVE-2017-16897?

CVE-2017-16897 is a high-severity authentication bypass vulnerability in n/a, published on 23 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2017-16897?

2 open source packages ship an affected version, including passport-wsfed-saml2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passport-wsfed-saml2` | npm | All versions | 3.0.5 |
| `passport-wsfed-saml2` | npm | All versions | 3.0.5 |

Products: Auth0 Passport-Wsfed-Saml2.

## How do I fix CVE-2017-16897?

Upgrade passport-wsfed-saml2 to 3.0.5 or later.

## Is CVE-2017-16897 being exploited?

There is no known exploitation of CVE-2017-16897 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-23505](https://insights.sbomify.com/CVE-2022-23505/): Passport-wsfed-saml2 vulnerable to Authentication Bypass for WSFed authentication (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16897 and fix it if it is affected.

What it is: CVE-2017-16897 is a high-severity authentication bypass vulnerability in n/a, published on 23 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16897 in the wild and no public exploit code.

Affected packages and fixed versions:
- passport-wsfed-saml2 (npm): affected all versions; fixed in 3.0.5
- passport-wsfed-saml2 (npm): affected all versions; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16897/ (Markdown: https://insights.sbomify.com/CVE-2017-16897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16897
- OSV: https://osv.dev/vulnerability/CVE-2017-16897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16897/
Summaries are generated and may contain mistakes; the official description above is the record.
