# CVE-2017-17042: Arbitrary file read vulnerability in yard server

> Attackers can read arbitrary files via directory traversal in the YARD server component, affecting users of the Ruby documentation tool.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Nov 2017
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-17042, GHSA-gj4p-3wh3-2rmf, SUSE-SU-2018:1890-1, UBUNTU-CVE-2017-17042, openSUSE-SU-2024:11532-1

## What is CVE-2017-17042?

CVE-2017-17042 is a high-severity path traversal vulnerability in n/a, published on 28 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lib/yard/core_ext/file.rb in the server in YARD before 0.9.11 does not block relative paths with an initial ../ sequence, which allows attackers to conduct directory traversal attacks and read arbitrary files.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-17042?

2 open source packages ship an affected version, including yard. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yard` | RubyGems | All versions | 0.9.11 |
| `yard` | RubyGems | All versions | 0.9.11 |
| `rubygem-yard` | SUSE:Linux Enterprise Software Development Kit 12 SP3 | All versions | 0.8.7.3-7.3.1 |

Products: Yardoc Yard.

## How do I fix CVE-2017-17042?

Upgrade yard to 0.9.11 or later.

## Is CVE-2017-17042 being exploited?

There is no known exploitation of CVE-2017-17042 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-1020001](https://insights.sbomify.com/CVE-2019-1020001/): Path Traversal vulnerability that affects yard (high 7.5)
- [CVE-2026-41493](https://insights.sbomify.com/CVE-2026-41493/): yard: Possible arbitrary path traversal and file access via yard server (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-17042 and fix it if it is affected.

What it is: CVE-2017-17042 is a high-severity path traversal vulnerability in n/a, published on 28 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-17042 in the wild and no public exploit code.

Affected packages and fixed versions:
- yard (RubyGems): affected all versions; fixed in 0.9.11
- yard (RubyGems): affected all versions; fixed in 0.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-17042/ (Markdown: https://insights.sbomify.com/CVE-2017-17042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-17042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-17042
- OSV: https://osv.dev/vulnerability/CVE-2017-17042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-17042/
Summaries are generated and may contain mistakes; the official description above is the record.
