{"answers":{"affected":"2 open source packages ship an affected version, including auth0-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-17068 in the wild and no public exploit code.","fix":"Upgrade auth0-js to 8.12.0 or later.","what":"CVE-2017-17068 is a high-severity vulnerability in n/a, published on 6 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-17068 and fix it if it is affected.\n\nWhat it is: CVE-2017-17068 is a high-severity vulnerability in n/a, published on 6 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-17068 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0-js (npm): affected all versions; fixed in 8.12.0\n- auth0-js (npm): affected all versions; fixed in 8.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-17068/ (Markdown: https://insights.sbomify.com/CVE-2017-17068/index.md)","id":"CVE-2017-17068","markdown":"https://insights.sbomify.com/CVE-2017-17068/index.md","name":"CVE-2017-17068","record":{"aliases":["GHSA-3rpr-mg43-xhq4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Auth0 JavaScript library","requires_auth":"none","summary":"Attackers can steal authenticated user tokens via popup callback pages, enabling service invocation on behalf of users.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"auth0.js","vendor":"auth0"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions \u003c 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"auth0-js Privilege Escalation Vulnerability","id":"CVE-2017-17068","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Other in n/a","id":"CVE-2017-17069"},"packages":[{"ecosystem":"npm","fixed":["8.12.0"],"introduced":["0"],"last_affected":[],"package":"auth0-js","purl":null,"source":"GHSA-3rpr-mg43-xhq4"},{"ecosystem":"npm","fixed":["8.12.0"],"introduced":["0"],"last_affected":[],"package":"auth0-js","purl":"pkg:npm/auth0-js","source":"GHSA-3rpr-mg43-xhq4"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2017-17067"},"products":["n/a"],"published":"2017-12-06","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2018-6873","kev_date_added":null,"published":"2018-04-04"},{"cvss_score":8.8,"headline":"Cross-Site Request Forgery (CSRF) in Auth0","id":"CVE-2018-6874","kev_date_added":null,"published":"2018-04-04"},{"cvss_score":8.8,"headline":"Auth0-js bypasses CSRF checks","id":"CVE-2018-7307","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":7.7,"headline":"Authorization header is not sanitized in an error object in auth0","id":"CVE-2020-15125","kev_date_added":null,"published":"2020-07-29"},{"cvss_score":7.1,"headline":"Improper Permission Checking in Auth.js SDK","id":"CVE-2026-42280","kev_date_added":null,"published":"2026-05-27"},{"cvss_score":5.5,"headline":"Information disclosure through error object","id":"CVE-2020-5263","kev_date_added":null,"published":"2020-04-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can steal authenticated user tokens via popup callback pages, enabling service invocation on behalf of users.","url":"https://insights.sbomify.com/CVE-2017-17068/"}