# CVE-2017-17068: auth0-js Privilege Escalation Vulnerability

> Attackers can steal authenticated user tokens via popup callback pages, enabling service invocation on behalf of users.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Dec 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-3rpr-mg43-xhq4

## What is CVE-2017-17068?

CVE-2017-17068 is a high-severity vulnerability in n/a, published on 6 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-17068?

2 open source packages ship an affected version, including auth0-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0-js` | npm | All versions | 8.12.0 |
| `auth0-js` | npm | All versions | 8.12.0 |

Products: Auth0 Auth0.js.

## How do I fix CVE-2017-17068?

Upgrade auth0-js to 8.12.0 or later.

## Is CVE-2017-17068 being exploited?

There is no known exploitation of CVE-2017-17068 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-6873](https://insights.sbomify.com/CVE-2018-6873/): Auth bypass in n/a (critical 9.8)
- [CVE-2018-6874](https://insights.sbomify.com/CVE-2018-6874/): Cross-Site Request Forgery (CSRF) in Auth0 (high 8.8)
- [CVE-2018-7307](https://insights.sbomify.com/CVE-2018-7307/): Auth0-js bypasses CSRF checks (high 8.8)
- [CVE-2020-15125](https://insights.sbomify.com/CVE-2020-15125/): Authorization header is not sanitized in an error object in auth0 (high 7.7)
- [CVE-2026-42280](https://insights.sbomify.com/CVE-2026-42280/): Improper Permission Checking in Auth.js SDK (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-17068 and fix it if it is affected.

What it is: CVE-2017-17068 is a high-severity vulnerability in n/a, published on 6 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-17068 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0-js (npm): affected all versions; fixed in 8.12.0
- auth0-js (npm): affected all versions; fixed in 8.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-17068/ (Markdown: https://insights.sbomify.com/CVE-2017-17068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-17068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-17068
- OSV: https://osv.dev/vulnerability/CVE-2017-17068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-17068/
Summaries are generated and may contain mistakes; the official description above is the record.
