# CVE-2017-17383: Cross-site Scripting in Jenkins Core

> Remote authenticated administrators can execute arbitrary scripts via crafted tool names in Jenkins job configurations, potentially compromising user sessions.

- **Severity:** Medium 4.7 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Dec 2017
- **Updated:** 5 Aug 2024
- **Also known as:** CVE-2018-1000016, GHSA-x3rc-cxv7-6xp6

## What is CVE-2017-17383?

CVE-2017-17383 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 6 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins through 2.93 allows remote authenticated administrators to conduct XSS attacks via a crafted tool name in a job configuration form, as demonstrated by the JDK tool in Jenkins core and the Ant tool in the Ant plugin, aka SECURITY-624.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-17383?

2 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.94 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.94 |

Products: Jenkins Jenkins.

## How do I fix CVE-2017-17383?

Upgrade org.jenkins-ci.main:jenkins-core to 2.94 or later.

## Is CVE-2017-17383 being exploited?

There is no known exploitation of CVE-2017-17383 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-17383 and fix it if it is affected.

What it is: CVE-2017-17383 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 6 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-17383 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.94
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.94

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-17383/ (Markdown: https://insights.sbomify.com/CVE-2017-17383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-17383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-17383
- OSV: https://osv.dev/vulnerability/CVE-2017-17383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-17383/
Summaries are generated and may contain mistakes; the official description above is the record.
