{"answers":{"affected":"3 open source packages ship an affected version, including mercurial. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-17458 in the wild and no public exploit code.","fix":"Upgrade mercurial to 4.4.1 or later.","what":"CVE-2017-17458 is a critical command injection vulnerability in Debian Debian Linux, published on 7 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-17458 and fix it if it is affected.\n\nWhat it is: CVE-2017-17458 is a critical command injection vulnerability in Debian Debian Linux, published on 7 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-17458 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mercurial (PyPI): affected all versions; fixed in 4.4.1\n- mercurial (PyPI): affected all versions; fixed in 4.4.1\n- mercurial (PyPI): affected all versions; fixed in 4.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-17458/ (Markdown: https://insights.sbomify.com/CVE-2017-17458/index.md)","id":"CVE-2017-17458","markdown":"https://insights.sbomify.com/CVE-2017-17458/index.md","name":"CVE-2017-17458","record":{"aliases":["DEBIAN-CVE-2017-17458","DLA-1224-1","DLA-1414-2","GHSA-6v56-cpg6-3rpx","MGASA-2018-0041","PYSEC-2017-90","SUSE-SU-2018:0127-1","SUSE-SU-2018:0129-1","UBUNTU-CVE-2017-17458"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Mercurial SCM","requires_auth":"none","summary":"A specially malformed Mercurial repository can trigger arbitrary code execution via Git hooks, affecting developers using Mercurial with Git subrepositories.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"mercurial","vendor":"mercurial"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.","ecosystems":["PyPI","SUSE:Linux Enterprise Software Development Kit 11 SP4","SUSE:Linux Enterprise Software Development Kit 12 SP2","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mercurial vulnerable to arbitrary code injection","id":"CVE-2017-17458","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"command_injection","year":"2017"},"n_packages":6,"n_references":9,"next":{"headline":"Command injection in n/a","id":"CVE-2017-17459"},"packages":[{"ecosystem":"PyPI","fixed":["4.4.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":null,"source":"GHSA-6v56-cpg6-3rpx"},{"ecosystem":"PyPI","fixed":["4.4.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:pypi/mercurial","source":"GHSA-6v56-cpg6-3rpx"},{"ecosystem":"PyPI","fixed":["4.4.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:pypi/mercurial","source":"PYSEC-2017-90"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["2.3.2-0.18.6.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:rpm/suse/mercurial\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2018:0127-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP2","fixed":["2.8.2-15.6.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:rpm/suse/mercurial\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP2","source":"SUSE-SU-2018:0129-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["2.8.2-15.6.1"],"introduced":["0"],"last_affected":[],"package":"mercurial","purl":"pkg:rpm/suse/mercurial\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:0129-1"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2017-17455"},"products":["n/a"],"published":"2017-12-07","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A specially malformed Mercurial repository can trigger arbitrary code execution via Git hooks, affecting developers using Mercurial with Git subrepositories.","url":"https://insights.sbomify.com/CVE-2017-17458/"}