# CVE-2017-17458: Mercurial vulnerable to arbitrary code injection

> A specially malformed Mercurial repository can trigger arbitrary code execution via Git hooks, affecting developers using Mercurial with Git subrepositories.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-17458, DLA-1224-1, DLA-1414-2, GHSA-6v56-cpg6-3rpx, MGASA-2018-0041, PYSEC-2017-90, SUSE-SU-2018:0127-1, SUSE-SU-2018:0129-1, UBUNTU-CVE-2017-17458

## What is CVE-2017-17458?

CVE-2017-17458 is a critical command injection vulnerability in Debian Debian Linux, published on 7 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2017-17458?

3 open source packages ship an affected version, including mercurial. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurial` | PyPI | All versions | 4.4.1 |
| `mercurial` | PyPI | All versions | 4.4.1 |
| `mercurial` | PyPI | All versions | 4.4.1 |
| `mercurial` | SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 2.3.2-0.18.6.1 |
| `mercurial` | SUSE:Linux Enterprise Software Development Kit 12 SP2 | All versions | 2.8.2-15.6.1 |
| `mercurial` | SUSE:Linux Enterprise Software Development Kit 12 SP3 | All versions | 2.8.2-15.6.1 |

Products: Debian Debian Linux, Mercurial Mercurial.

## How do I fix CVE-2017-17458?

Upgrade mercurial to 4.4.1 or later.

## Is CVE-2017-17458 being exploited?

There is no known exploitation of CVE-2017-17458 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-17458 and fix it if it is affected.

What it is: CVE-2017-17458 is a critical command injection vulnerability in Debian Debian Linux, published on 7 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-17458 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercurial (PyPI): affected all versions; fixed in 4.4.1
- mercurial (PyPI): affected all versions; fixed in 4.4.1
- mercurial (PyPI): affected all versions; fixed in 4.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-17458/ (Markdown: https://insights.sbomify.com/CVE-2017-17458/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-17458
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-17458
- OSV: https://osv.dev/vulnerability/CVE-2017-17458

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-17458/
Summaries are generated and may contain mistakes; the official description above is the record.
