{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-17663 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-17663 is a critical memory corruption vulnerability in n/a, published on 6 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-17663 and fix it if it is affected.\n\nWhat it is: CVE-2017-17663 is a critical memory corruption vulnerability in n/a, published on 6 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-17663 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-17663/ (Markdown: https://insights.sbomify.com/CVE-2017-17663/index.md)","id":"CVE-2017-17663","markdown":"https://insights.sbomify.com/CVE-2017-17663/index.md","name":"CVE-2017-17663","record":{"aliases":["ALPINE-CVE-2017-17663","DEBIAN-CVE-2017-17663","GHSA-mrjc-pvrp-jc53","UBUNTU-CVE-2017-17663","openSUSE-SU-2024:11460-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"HTTP server","requires_auth":"none","summary":"A buffer overflow in the htpasswd implementation of mini_httpd and thttpd allows remote attackers to execute arbitrary code.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mini_httpd","vendor":"acme"},{"product":"thttpd","vendor":"acme"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2017-17663","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2017"},"n_packages":1,"n_references":1,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-17664"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.29-3.9"],"introduced":["0"],"last_affected":[],"package":"thttpd","purl":"pkg:rpm/opensuse/thttpd\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11460-1"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2017-17662"},"products":["n/a"],"published":"2018-02-06","related":[{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2015-1548","kev_date_added":null,"published":"2015-02-10"},{"cvss_score":5,"headline":"Command injection in n/a","id":"CVE-2009-4490","kev_date_added":null,"published":"2010-01-13"},{"cvss_score":5,"headline":"Path traversal in n/a","id":"CVE-2001-0893","kev_date_added":null,"published":"2002-02-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A buffer overflow in the htpasswd implementation of mini_httpd and thttpd allows remote attackers to execute arbitrary code.","url":"https://insights.sbomify.com/CVE-2017-17663/"}