{"answers":{"affected":"2 open source packages ship an affected version, including net-ldap. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-17718 in the wild and no public exploit code.","fix":"Upgrade net-ldap to 0.16.0 or later.","what":"CVE-2017-17718 is a medium-severity vulnerability in n/a, published on 17 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-17718 and fix it if it is affected.\n\nWhat it is: CVE-2017-17718 is a medium-severity vulnerability in n/a, published on 17 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-17718 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- net-ldap (RubyGems): affected all versions; fixed in 0.16.0\n- net-ldap (RubyGems): affected all versions; fixed in 0.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-17718/ (Markdown: https://insights.sbomify.com/CVE-2017-17718/index.md)","id":"CVE-2017-17718","markdown":"https://insights.sbomify.com/CVE-2017-17718/index.md","name":"CVE-2017-17718","record":{"aliases":["DEBIAN-CVE-2017-17718","GHSA-m7p8-9w66-9frm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby LDAP library","requires_auth":"none","summary":"The net-ldap Ruby gem fails to validate SSL certificates, allowing attackers to bypass security checks and potentially intercept or manipulate LDAP communications.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"net-ldap","vendor":"net-ldap_project"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"The Net::LDAP (aka net-ldap) gem before 0.16.0 for Ruby has Missing SSL Certificate Validation.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"net-ldap Improper Certificate Validation vulnerability","id":"CVE-2017-17718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-17719"},"packages":[{"ecosystem":"RubyGems","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"net-ldap","purl":null,"source":"GHSA-m7p8-9w66-9frm"},{"ecosystem":"RubyGems","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"net-ldap","purl":"pkg:gem/net-ldap","source":"GHSA-m7p8-9w66-9frm"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2017-17717"},"products":["n/a"],"published":"2017-12-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"The net-ldap Ruby gem fails to validate SSL certificates, allowing attackers to bypass security checks and potentially intercept or manipulate LDAP communications.","url":"https://insights.sbomify.com/CVE-2017-17718/"}