# CVE-2017-17718: net-ldap Improper Certificate Validation vulnerability

> The net-ldap Ruby gem fails to validate SSL certificates, allowing attackers to bypass security checks and potentially intercept or manipulate LDAP communications.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-17718, GHSA-m7p8-9w66-9frm

## What is CVE-2017-17718?

CVE-2017-17718 is a medium-severity vulnerability in n/a, published on 17 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Net::LDAP (aka net-ldap) gem before 0.16.0 for Ruby has Missing SSL Certificate Validation.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2017-17718?

2 open source packages ship an affected version, including net-ldap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net-ldap` | RubyGems | All versions | 0.16.0 |
| `net-ldap` | RubyGems | All versions | 0.16.0 |

Products: Net-Ldap Project Net-Ldap.

## How do I fix CVE-2017-17718?

Upgrade net-ldap to 0.16.0 or later.

## Is CVE-2017-17718 being exploited?

There is no known exploitation of CVE-2017-17718 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-17718 and fix it if it is affected.

What it is: CVE-2017-17718 is a medium-severity vulnerability in n/a, published on 17 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-17718 in the wild and no public exploit code.

Affected packages and fixed versions:
- net-ldap (RubyGems): affected all versions; fixed in 0.16.0
- net-ldap (RubyGems): affected all versions; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-17718/ (Markdown: https://insights.sbomify.com/CVE-2017-17718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-17718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-17718
- OSV: https://osv.dev/vulnerability/CVE-2017-17718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-17718/
Summaries are generated and may contain mistakes; the official description above is the record.
