{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2017-17740 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2017-17740 is a high-severity use after free vulnerability in Openldap Openldap, published on 18 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-17740 and fix it if it is affected.\n\nWhat it is: CVE-2017-17740 is a high-severity use after free vulnerability in Openldap Openldap, published on 18 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-17740 in the wild and no public exploit code.\n\nAffected product: Openldap Openldap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-17740/ (Markdown: https://insights.sbomify.com/CVE-2017-17740/index.md)","id":"CVE-2017-17740","markdown":"https://insights.sbomify.com/CVE-2017-17740/index.md","name":"CVE-2017-17740","record":{"aliases":["ALPINE-CVE-2017-17740","CLEANSTART-2026-UO26134","DEBIAN-CVE-2017-17740","GHSA-h7vm-9jwq-6c9r","ROOT-OS-DEBIAN-12-CVE-2017-17740","SUSE-SU-2018:4150-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenLDAP server","requires_auth":"none","summary":"Remote attackers can crash the OpenLDAP server via a member MODDN operation when the nops module and memberof overlay are enabled.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"policy_auditor","vendor":"mcafee"},{"product":"openldap","vendor":"openldap"},{"product":"leap","vendor":"opensuse"},{"product":"blockchain_platform","vendor":"oracle"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"contrib/slapd-modules/nops/nops.c in OpenLDAP through 2.4.45, when both the nops module and the memberof overlay are enabled, attempts to free a buffer that was allocated on the stack, which allows remote attackers to cause a denial of service (slapd crash) via a member MODDN operation.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Desktop 12 SP4","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server 12 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 12 SP4","SUSE:Linux Enterprise Software Development Kit 12 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in n/a","id":"CVE-2017-17740","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"openldap:openldap","products":["openldap:openldap","opensuse:leap"],"type":"use_after_free","year":"2017"},"n_packages":8,"n_references":5,"next":{"headline":"Information disclosure in n/a","id":"CVE-2017-17741"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["2.4.41-18.43.1"],"introduced":["0"],"last_affected":[],"package":"openldap2","purl":"pkg:rpm/suse/openldap2\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:4150-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP4","fixed":["2.4.41-18.43.1"],"introduced":["0"],"last_affected":[],"package":"openldap2","purl":"pkg:rpm/suse/openldap2\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP4","source":"SUSE-SU-2018:4150-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["2.4.41-18.43.1"],"introduced":["0"],"last_affected":[],"package":"openldap2","purl":"pkg:rpm/suse/openldap2\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:4150-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP4","fixed":["2.4.41-18.43.1"],"introduced":["0"],"last_affected":[],"package":"openldap2","purl":"pkg:rpm/suse/openldap2\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP4","source":"SUSE-SU-2018:4150-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["2.4.41-18.43.1"],"introduced":["0"],"last_affected":[],"package":"openldap2","purl":"pkg:rpm/suse/openldap2\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:4150-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP4","fixed":["2.4.41-18.43.1"],"introduced":["0"],"last_affected":[],"package":"openldap2","purl":"pkg:rpm/suse/openldap2\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP4","source":"SUSE-SU-2018:4150-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["2.4.41-18.43.1"],"introduced":["0"],"last_affected":[],"package":"openldap2","purl":"pkg:rpm/suse/openldap2\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:4150-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP4","fixed":["2.4.41-18.43.1"],"introduced":["0"],"last_affected":[],"package":"openldap2","purl":"pkg:rpm/suse/openldap2\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP4","source":"SUSE-SU-2018:4150-1"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2017-17739"},"products":["n/a"],"published":"2017-12-18","related":[{"cvss_score":6.1,"headline":"Cross-Site Scripting vulnerability in Policy Auditor","id":"CVE-2021-31851","kev_date_added":null,"published":"2021-11-23"},{"cvss_score":6.1,"headline":"Cross-Site Scripting vulnerability in Policy Auditor","id":"CVE-2021-31852","kev_date_added":null,"published":"2021-11-23"},{"cvss_score":4.2,"headline":"Security feature bypass in n/a","id":"CVE-2020-15719","kev_date_added":null,"published":"2020-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can crash the OpenLDAP server via a member MODDN operation when the nops module and memberof overlay are enabled.","url":"https://insights.sbomify.com/CVE-2017-17740/"}