# CVE-2017-17835: Cross-Site Request Forgery (CSRF) in Apache Airflow

> A CSRF vulnerability in Apache Airflow allows remote attackers to execute arbitrary commands on default installations.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-68wv-rjrm-576p, PYSEC-2019-148

## What is CVE-2017-17835?

CVE-2017-17835 is a high-severity vulnerability in Apache Airflow, published on 23 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Apache Airflow 1.8.2 and earlier, a CSRF vulnerability allowed for a remote command injection on a default install of Airflow.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-17835?

3 open source packages ship an affected version, including apache-airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 1.9.0 |
| `apache-airflow` | PyPI | All versions | 1.9.0 |
| `apache-airflow` | PyPI | All versions | 1.9.0 |

Products: Apache Airflow.

## How do I fix CVE-2017-17835?

Upgrade apache-airflow to 1.9.0 or later.

## Is CVE-2017-17835 being exploited?

There is no known exploitation of CVE-2017-17835 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-17835 and fix it if it is affected.

What it is: CVE-2017-17835 is a high-severity vulnerability in Apache Airflow, published on 23 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-17835 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 1.9.0
- apache-airflow (PyPI): affected all versions; fixed in 1.9.0
- apache-airflow (PyPI): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-17835/ (Markdown: https://insights.sbomify.com/CVE-2017-17835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-17835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-17835
- OSV: https://osv.dev/vulnerability/CVE-2017-17835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-17835/
Summaries are generated and may contain mistakes; the official description above is the record.
