{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.deltaspike.modules:jsf-module-project. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-17837 in the wild and no public exploit code.","fix":"Upgrade org.apache.deltaspike.modules:jsf-module-project to 1.8.1 or later.","what":"CVE-2017-17837 is a medium-severity cross-site scripting vulnerability in Apache DeltaSpike, published on 4 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-17837 and fix it if it is affected.\n\nWhat it is: CVE-2017-17837 is a medium-severity cross-site scripting vulnerability in Apache DeltaSpike, published on 4 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-17837 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.deltaspike.modules:jsf-module-project (Maven): affected all versions; fixed in 1.8.1\n- org.apache.deltaspike.modules:jsf-module-project (Maven): affected all versions; fixed in 1.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-17837/ (Markdown: https://insights.sbomify.com/CVE-2017-17837/index.md)","id":"CVE-2017-17837","markdown":"https://insights.sbomify.com/CVE-2017-17837/index.md","name":"CVE-2017-17837","record":{"aliases":["GHSA-4q23-g7mf-xp98"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Java JSF library","requires_auth":"none","summary":"Cross-site scripting vulnerability in Apache DeltaSpike-JSF allows attackers to inject malicious scripts via windowId handling, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"deltaspike","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Apache DeltaSpike-JSF 1.8.0 module has a XSS injection leak in the windowId handling. The default size of the windowId get's cut off after 10 characters (by default), so the impact might be limited. A fix got applied and released in Apache deltaspike-1.8.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Apache DeltaSpike","id":"CVE-2017-17837","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-17838"},"packages":[{"ecosystem":"Maven","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.deltaspike.modules:jsf-module-project","purl":null,"source":"GHSA-4q23-g7mf-xp98"},{"ecosystem":"Maven","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.deltaspike.modules:jsf-module-project","purl":"pkg:maven/org.apache.deltaspike.modules/jsf-module-project","source":"GHSA-4q23-g7mf-xp98"}],"prev":{"headline":"Apache Airflow vulnerable to XSS","id":"CVE-2017-17836"},"products":["Apache DeltaSpike"],"published":"2018-01-04","related":[{"cvss_score":6.1,"headline":"Injection in DeltaSpike","id":"CVE-2019-12416","kev_date_added":null,"published":"2020-03-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"Cross-site scripting vulnerability in Apache DeltaSpike-JSF allows attackers to inject malicious scripts via windowId handling, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2017-17837/"}