# CVE-2017-17837: Cross-site Scripting in Apache DeltaSpike

> Cross-site scripting vulnerability in Apache DeltaSpike-JSF allows attackers to inject malicious scripts via windowId handling, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jan 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-4q23-g7mf-xp98

## What is CVE-2017-17837?

CVE-2017-17837 is a medium-severity cross-site scripting vulnerability in Apache DeltaSpike, published on 4 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Apache DeltaSpike-JSF 1.8.0 module has a XSS injection leak in the windowId handling. The default size of the windowId get's cut off after 10 characters (by default), so the impact might be limited. A fix got applied and released in Apache deltaspike-1.8.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-17837?

2 open source packages ship an affected version, including org.apache.deltaspike.modules:jsf-module-project. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.deltaspike.modules:jsf-module-project` | Maven | All versions | 1.8.1 |
| `org.apache.deltaspike.modules:jsf-module-project` | Maven | All versions | 1.8.1 |

Products: Apache Deltaspike.

## How do I fix CVE-2017-17837?

Upgrade org.apache.deltaspike.modules:jsf-module-project to 1.8.1 or later.

## Is CVE-2017-17837 being exploited?

There is no known exploitation of CVE-2017-17837 in the wild and no public exploit code.

## Other vulnerabilities in Apache DeltaSpike

- [CVE-2019-12416](https://insights.sbomify.com/CVE-2019-12416/): Injection in DeltaSpike (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-17837 and fix it if it is affected.

What it is: CVE-2017-17837 is a medium-severity cross-site scripting vulnerability in Apache DeltaSpike, published on 4 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-17837 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.deltaspike.modules:jsf-module-project (Maven): affected all versions; fixed in 1.8.1
- org.apache.deltaspike.modules:jsf-module-project (Maven): affected all versions; fixed in 1.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-17837/ (Markdown: https://insights.sbomify.com/CVE-2017-17837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-17837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-17837
- OSV: https://osv.dev/vulnerability/CVE-2017-17837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-17837/
Summaries are generated and may contain mistakes; the official description above is the record.
