{"answers":{"affected":"2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-17899 in the wild and no public exploit code.","fix":"Upgrade dolibarr/dolibarr to 6.0.5 or later.","what":"CVE-2017-17899 is a critical SQL injection vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 24 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-17899 and fix it if it is affected.\n\nWhat it is: CVE-2017-17899 is a critical SQL injection vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 24 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-17899 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 6.0.5\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 6.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-17899/ (Markdown: https://insights.sbomify.com/CVE-2017-17899/index.md)","id":"CVE-2017-17899","markdown":"https://insights.sbomify.com/CVE-2017-17899/index.md","name":"CVE-2017-17899","record":{"aliases":["GHSA-7789-v767-37r5","UBUNTU-CVE-2017-17899"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Dolibarr ERP/CRM","requires_auth":"none","summary":"Remote attackers can execute arbitrary SQL commands via the rowid parameter in Dolibarr ERP/CRM, potentially compromising database integrity and confidentiality.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dolibarr_erp\\/crm","vendor":"dolibarr"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"SQL injection vulnerability in adherents/subscription/info.php in Dolibarr ERP/CRM version 6.0.4 allows remote attackers to execute arbitrary SQL commands via the rowid parameter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dolibarr SQL injection vulnerability in adherents/subscription/info.php","id":"CVE-2017-17899","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"dolibarr:dolibarr_erp\\/crm","products":["dolibarr:dolibarr_erp\\/crm"],"type":"sql_injection","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Dolibarr SQL injection vulnerability in fourn/index.php","id":"CVE-2017-17900"},"packages":[{"ecosystem":"Packagist","fixed":["6.0.5"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":null,"source":"GHSA-7789-v767-37r5"},{"ecosystem":"Packagist","fixed":["6.0.5"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":"pkg:composer/dolibarr/dolibarr","source":"GHSA-7789-v767-37r5"}],"prev":{"headline":"Dolibarr sensitive information disclosure","id":"CVE-2017-17898"},"products":["n/a"],"published":"2017-12-24","related":[{"cvss_score":9.8,"headline":"Dolibarr vulnerable to privilege escalation","id":"CVE-2022-43138","kev_date_added":null,"published":"2022-11-17"},{"cvss_score":9.8,"headline":"Dolibarr vulnerable to Eval Injection","id":"CVE-2022-40871","kev_date_added":null,"published":"2022-10-12"},{"cvss_score":9.8,"headline":"Dolibarr remote PHP code execution","id":"CVE-2021-33816","kev_date_added":null,"published":"2021-11-10"},{"cvss_score":9.8,"headline":"Dolibarr Improper Restriction of Excessive Authentication Attempts","id":"CVE-2020-7995","kev_date_added":null,"published":"2020-01-26"},{"cvss_score":9.8,"headline":"SQL injection in dolibarr","id":"CVE-2013-2091","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Command injection in dolibarr","id":"CVE-2013-2093","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in product/card.php","id":"CVE-2018-13447","kev_date_added":null,"published":"2018-07-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary SQL commands via the rowid parameter in Dolibarr ERP/CRM, potentially compromising database integrity and confidentiality.","url":"https://insights.sbomify.com/CVE-2017-17899/"}