# CVE-2017-17971: Dolibarr ERP and CRM contain XSS Vulnerability

> Insufficient input filtering in Dolibarr allows attackers to inject malicious scripts via onclick or onscroll attributes, leading to cross-site scripting.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Dec 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-qjq9-wx5j-jrg6, UBUNTU-CVE-2017-17971

## What is CVE-2017-17971?

CVE-2017-17971 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 29 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The test_sql_and_script_inject function in htdocs/main.inc.php in Dolibarr ERP/CRM 6.0.4 blocks some event attributes but neither onclick nor onscroll, which allows XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-17971?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 6.0.5 |
| `dolibarr/dolibarr` | Packagist | All versions | 6.0.5 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2017-17971?

Upgrade dolibarr/dolibarr to 6.0.5 or later.

## Is CVE-2017-17971 being exploited?

There is no known exploitation of CVE-2017-17971 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-17971 and fix it if it is affected.

What it is: CVE-2017-17971 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 29 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-17971 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 6.0.5
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 6.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-17971/ (Markdown: https://insights.sbomify.com/CVE-2017-17971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-17971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-17971
- OSV: https://osv.dev/vulnerability/CVE-2017-17971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-17971/
Summaries are generated and may contain mistakes; the official description above is the record.
