# CVE-2017-18009: Out-of-bounds Read in OpenCV

> A heap-based buffer over-read in OpenCV's HDR decoder allows attackers to cause denial of service or disclose sensitive memory contents.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-18009, GHSA-83rh-hx5x-q9p5, PYSEC-2026-2810, PYSEC-2026-702

## What is CVE-2017-18009?

CVE-2017-18009 is a high-severity memory corruption vulnerability in n/a, published on 1 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In OpenCV 3.3.1, a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2017-18009?

6 open source packages ship an affected version, including opencv-contrib-python and opencv-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencv-contrib-python` | PyPI | All versions | 3.4.1.15 |
| `opencv-contrib-python` | PyPI | All versions | 3.4.1.15 |
| `opencv-contrib-python` | PyPI | All versions | 3.4.1.15 |
| `opencv-python` | PyPI | All versions | 3.4.1.15 |
| `opencv-python` | PyPI | All versions | 3.4.1.15 |
| `opencv-python` | PyPI | All versions | 3.4.1.15 |

Products: Opencv Opencv.

## How do I fix CVE-2017-18009?

Upgrade opencv-contrib-python to 3.4.1.15 or later.

## Is CVE-2017-18009 being exploited?

There is no known exploitation of CVE-2017-18009 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-5063](https://insights.sbomify.com/CVE-2019-5063/): Out-of-bounds Write in OpenCV (high 8.8)
- [CVE-2019-5064](https://insights.sbomify.com/CVE-2019-5064/): Out-of-bounds Write in OpenCV (high 8.8)
- [CVE-2019-14491](https://insights.sbomify.com/CVE-2019-14491/): Out-of-bounds Read in OpenCV (high 8.2)
- [CVE-2019-14492](https://insights.sbomify.com/CVE-2019-14492/): Out-of-bounds Read and Out-of-bounds Write in OpenCV (high 7.5)
- [CVE-2018-7712](https://insights.sbomify.com/CVE-2018-7712/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18009 and fix it if it is affected.

What it is: CVE-2017-18009 is a high-severity memory corruption vulnerability in n/a, published on 1 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18009 in the wild and no public exploit code.

Affected packages and fixed versions:
- opencv-contrib-python (PyPI): affected all versions; fixed in 3.4.1.15
- opencv-contrib-python (PyPI): affected all versions; fixed in 3.4.1.15
- opencv-contrib-python (PyPI): affected all versions; fixed in 3.4.1.15
- opencv-python (PyPI): affected all versions; fixed in 3.4.1.15
- opencv-python (PyPI): affected all versions; fixed in 3.4.1.15
- opencv-python (PyPI): affected all versions; fixed in 3.4.1.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18009/ (Markdown: https://insights.sbomify.com/CVE-2017-18009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18009
- OSV: https://osv.dev/vulnerability/CVE-2017-18009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18009/
Summaries are generated and may contain mistakes; the official description above is the record.
