# CVE-2017-18037: Path traversal in Bitbucket Server

> Remote attackers can read arbitrary files via path traversal in the git tag resource, affecting Atlassian Bitbucket Server users.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Feb 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-hc32-j6f3-59m8

## What is CVE-2017-18037?

CVE-2017-18037 is a medium-severity path traversal vulnerability in Atlassian Bitbucket Server, published on 2 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The git repository tag rest resource in Atlassian Bitbucket Server from version 3.7.0 before 4.14.11 (the fixed version for 4.14.x), from version 5.0.0 before 5.0.9 (the fixed version for 5.0.x), from version 5.1.0 before 5.1.8 (the fixed version for 5.1.x), from version 5.2.0 before 5.2.6 (the fixed version for 5.2.x), from version 5.3.0 before 5.3.4 (the fixed version for 5.3.x), from version 5.4.0 before 5.4.2 (the fixed version for 5.4.x), from version 5.5.0 before 5.5.1 (the fixed version for 5.5.x) and before 5.6.0 allows remote attackers to read arbitrary files via a path traversal vulnerability through the name of a git tag.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-18037?

It affects 1 product.


Products: Atlassian Bitbucket.

## How do I fix CVE-2017-18037?

No fix has been published for CVE-2017-18037 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-18037 being exploited?

There is no known exploitation of CVE-2017-18037 in the wild and no public exploit code.

## Other vulnerabilities in Atlassian Bitbucket Server

- [CVE-2022-36804](https://insights.sbomify.com/CVE-2022-36804/): Atlassian Bitbucket Server and Data Center Command Injection (high 8.8, exploited in the wild)
- [CVE-2018-5225](https://insights.sbomify.com/CVE-2018-5225/): Path traversal in Bitbucket Server (critical 9.9)
- [CVE-2022-43781](https://insights.sbomify.com/CVE-2022-43781/): Command injection in Bitbucket Data Center (critical 9.8)
- [CVE-2019-15000](https://insights.sbomify.com/CVE-2019-15000/): Command injection in Bitbucket Data Center (critical 9.8)
- [CVE-2019-3397](https://insights.sbomify.com/CVE-2019-3397/): Path traversal in Bitbucket Data Center (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18037 and fix it if it is affected.

What it is: CVE-2017-18037 is a medium-severity path traversal vulnerability in Atlassian Bitbucket Server, published on 2 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-18037 in the wild and no public exploit code.

Affected product: Atlassian Bitbucket Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18037/ (Markdown: https://insights.sbomify.com/CVE-2017-18037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18037
- OSV: https://osv.dev/vulnerability/CVE-2017-18037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18037/
Summaries are generated and may contain mistakes; the official description above is the record.
