# CVE-2017-18049: SilverStripe CSV Excel Macro Injection

> Attackers can inject malicious macros or scripts into CSV exports, leading to code execution when victims import the file into applications like Microsoft Excel.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2jvj-mhf2-g99w

## What is CVE-2017-18049?

CVE-2017-18049 is a medium-severity code injection vulnerability in Silverstripe Silverstripe, published on 23 Jan 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In the CSV export feature of SilverStripe before 3.5.6, 3.6.x before 3.6.3, and 4.x before 4.0.1, it's possible for the output to contain macros and scripts, which may be executed if imported without sanitization into common software (including Microsoft Excel). For example, the CSV data may contain untrusted user input from the "First Name" field of a user's /myprofile page.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2017-18049?

6 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | All versions | 3.5.6 |
| `silverstripe/framework` | Packagist | All versions | 3.5.6 |
| `silverstripe/framework` | Packagist | From 3.6.0 | 3.6.3 |
| `silverstripe/framework` | Packagist | From 3.6.0 | 3.6.3 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.0.1 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.0.1 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2017-18049?

Upgrade silverstripe/framework to a fixed version for your release line: 3.5.6, 3.6.3 or 4.0.1.

## Is CVE-2017-18049 being exploited?

There is no known exploitation of CVE-2017-18049 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18049 and fix it if it is affected.

What it is: CVE-2017-18049 is a medium-severity code injection vulnerability in Silverstripe Silverstripe, published on 23 Jan 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-18049 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected all versions; fixed in 3.5.6
- silverstripe/framework (Packagist): affected all versions; fixed in 3.5.6
- silverstripe/framework (Packagist): affected from 3.6.0; fixed in 3.6.3
- silverstripe/framework (Packagist): affected from 3.6.0; fixed in 3.6.3
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.0.1
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18049/ (Markdown: https://insights.sbomify.com/CVE-2017-18049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18049
- OSV: https://osv.dev/vulnerability/CVE-2017-18049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18049/
Summaries are generated and may contain mistakes; the official description above is the record.
