{"answers":{"affected":"2 open source packages ship an affected version, including omniauth. It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-18076 in the wild and no public exploit code.","fix":"Upgrade omniauth to 1.3.2 or later.","what":"CVE-2017-18076 is a high-severity vulnerability in Debian Debian Linux, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-18076 and fix it if it is affected.\n\nWhat it is: CVE-2017-18076 is a high-severity vulnerability in Debian Debian Linux, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-18076 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omniauth (RubyGems): affected all versions; fixed in 1.3.2\n- omniauth (RubyGems): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-18076/ (Markdown: https://insights.sbomify.com/CVE-2017-18076/index.md)","id":"CVE-2017-18076","markdown":"https://insights.sbomify.com/CVE-2017-18076/index.md","name":"CVE-2017-18076","record":{"aliases":["DEBIAN-CVE-2017-18076","DSA-4109-1","GHSA-9pr6-grf4-x2fr","UBUNTU-CVE-2017-18076"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby authentication library","requires_auth":"none","summary":"Attackers can bypass CSRF protection in OmniAuth by exploiting improper handling of POST parameters in the callback phase.","user_interaction":"not_required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"omniauth","vendor":"omniauth"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[],"description":"In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Omniauth allows POST parameters to be stored in session","id":"CVE-2017-18076","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"csrf","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"ReDoS in brace-expansion","id":"CVE-2017-18077"},"packages":[{"ecosystem":"RubyGems","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"omniauth","purl":null,"source":"GHSA-9pr6-grf4-x2fr"},{"ecosystem":"RubyGems","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"omniauth","purl":"pkg:gem/omniauth","source":"GHSA-9pr6-grf4-x2fr"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2017-18075"},"products":["n/a"],"published":"2018-01-26","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass CSRF protection in OmniAuth by exploiting improper handling of POST parameters in the callback phase.","url":"https://insights.sbomify.com/CVE-2017-18076/"}