{"answers":{"affected":"2 open source packages ship an affected version, including brace-expansion. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-18077 in the wild and no public exploit code.","fix":"Upgrade brace-expansion to 1.1.7 or later.","what":"CVE-2017-18077 is a high-severity denial of service vulnerability in n/a, published on 27 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-18077 and fix it if it is affected.\n\nWhat it is: CVE-2017-18077 is a high-severity denial of service vulnerability in n/a, published on 27 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-18077 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- brace-expansion (npm): affected all versions; fixed in 1.1.7\n- brace-expansion (npm): affected all versions; fixed in 1.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-18077/ (Markdown: https://insights.sbomify.com/CVE-2017-18077/index.md)","id":"CVE-2017-18077","markdown":"https://insights.sbomify.com/CVE-2017-18077/index.md","name":"CVE-2017-18077","record":{"aliases":["CLSA-2026-1792163293","DEBIAN-CVE-2017-18077","GHSA-832h-xg76-4gv6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the brace-expansion library by providing specially crafted input that triggers excessive regular expression processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"brace_expansion","vendor":"brace_expansion_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ReDoS in brace-expansion","id":"CVE-2017-18077","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2017-18078"},"packages":[{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"brace-expansion","purl":null,"source":"GHSA-832h-xg76-4gv6"},{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"brace-expansion","purl":"pkg:npm/brace-expansion","source":"GHSA-832h-xg76-4gv6"}],"prev":{"headline":"Omniauth allows POST parameters to be stored in session","id":"CVE-2017-18076"},"products":["n/a"],"published":"2018-01-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using the brace-expansion library by providing specially crafted input that triggers excessive regular expression processing.","url":"https://insights.sbomify.com/CVE-2017-18077/"}