CVE-2017-18089 Cross-site scripting in Crucible
Remote attackers can inject arbitrary HTML or JavaScript via invited reviewers in Atlassian Crucible, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2017-18089?
CVE-2017-18089 is a medium-severity cross-site scripting vulnerability in Atlassian Crucible, published on 16 Feb 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The view review history resource in Atlassian Crucible before version 4.4.3 (the fixed version for 4.4.x) and 4.5.0 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability through the invited reviewers for a review.
Weakness: CWE-79
Which versions are affected by CVE-2017-18089?
It affects 1 product.
Products include Atlassian Crucible.
How do I fix CVE-2017-18089?
No fix has been published for CVE-2017-18089 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-18089 being exploited?
There is no known exploitation of CVE-2017-18089 in the wild and no public exploit code.
Other vulnerabilities in Atlassian Crucible
Sources
Also known as GHSA-2fwm-m84p-x5qh.