CVE-2017-18090 Cross-site scripting in Fisheye

Medium 6.1 Published Updated

Remote attackers can inject arbitrary HTML or JavaScript via commit author names in Atlassian Fisheye, potentially leading to session hijacking or malicious script execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2017-18090?

CVE-2017-18090 is a medium-severity cross-site scripting vulnerability in Atlassian Fisheye, published on 16 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Various resources in Atlassian Fisheye before version 4.5.1 (the fixed version for 4.5.x) and before version 4.6.0 allow remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability in the name of a commit author.

Weakness: CWE-79

Which versions are affected by CVE-2017-18090?

It affects 1 product.

Products include Atlassian Fisheye.

How do I fix CVE-2017-18090?

No fix has been published for CVE-2017-18090 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-18090 being exploited?

There is no known exploitation of CVE-2017-18090 in the wild and no public exploit code.

All Atlassian Fisheye vulnerabilities

Sources

Also known as GHSA-76h4-p844-g65h.

Is CVE-2017-18090 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free