# CVE-2017-18090: Cross-site scripting in Fisheye

> Remote attackers can inject arbitrary HTML or JavaScript via commit author names in Atlassian Fisheye, potentially leading to session hijacking or malicious script execution.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Feb 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-76h4-p844-g65h

## What is CVE-2017-18090?

CVE-2017-18090 is a medium-severity cross-site scripting vulnerability in Atlassian Fisheye, published on 16 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Various resources in Atlassian Fisheye before version 4.5.1 (the fixed version for 4.5.x) and before version 4.6.0 allow remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability in the name of a commit author.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-18090?

It affects 1 product.


Products: Atlassian Fisheye.

## How do I fix CVE-2017-18090?

No fix has been published for CVE-2017-18090 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-18090 being exploited?

There is no known exploitation of CVE-2017-18090 in the wild and no public exploit code.

## Other vulnerabilities in Atlassian Fisheye

- [CVE-2017-18112](https://insights.sbomify.com/CVE-2017-18112/): Information disclosure in Fisheye (medium 6.5)
- [CVE-2017-9510](https://insights.sbomify.com/CVE-2017-9510/): Cross-site scripting in Atlassian Fisheye (medium 5.4)
- [CVE-2011-4822](https://insights.sbomify.com/CVE-2011-4822/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-18090 and fix it if it is affected.

What it is: CVE-2017-18090 is a medium-severity cross-site scripting vulnerability in Atlassian Fisheye, published on 16 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-18090 in the wild and no public exploit code.

Affected product: Atlassian Fisheye. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-18090/ (Markdown: https://insights.sbomify.com/CVE-2017-18090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-18090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-18090
- OSV: https://osv.dev/vulnerability/CVE-2017-18090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-18090/
Summaries are generated and may contain mistakes; the official description above is the record.
